New Ryzen 3700x upgrade 3 times worse performance?

"
sapman78 wrote:
Thanks a lot Novumaurum for your video and thanks Fitzy_GGG for your feedback.

:-)


+1
Thx alot
thanks. for whats its worth, i'm using cyclone build. not sure if other characters in the group will affect frame rate but i'm getting it all the time.
This is not a ryzen-specific issue.
Don't move my threads. You MUST ASK me BEFORE sending me a PM; failure results in the swift deletion of your unopened mail (Per 1st Amendment.)
"
bvanharjr wrote:
This is not a ryzen-specific issue.


Whys that what other CPU's are having this issue ? did you watch that youtube vid of the intel cpu vs the ryzen 3000?
Upgraded from i7 4790k @ 4.7ghz all cores, 2400mhz ddr3 2500 cl10 ram and 1080 to:

ryzen 3700x 3200mhz cl14 ddr4, x570 msi mpg pro gaming carbon wifi board and same gpu.

Running cyclone headhunter with 3x inspired learning is so much worse then with the 5 year old intel setup. But even without HH and IL the performance is abysmal. Definitely something is up.
Has it been fixed? Looking to play Blight but defo can't play if this issue is still there.
NO update :/ Hope this is not getting swept under the rug.
"
ocp15k wrote:
Has it been fixed? Looking to play Blight but defo can't play if this issue is still there.


"
pitbull2k wrote:
NO update :/ Hope this is not getting swept under the rug.


We're still working on it. :)
Thanks for the update!
Upgraded from 1800x to 3900x and it seems unplayable. No issues before on the 1800x. Now i get massive laggy framedrops.

So far of the games i have tested poe is the only one i have an issue with.

Same GPU as before vega64.

Mobo and ram is upgraded. g.skill tridentz 3600 cl16 and asus rog strix-f using the latest stable bios from asus. Seems my frames are higher but when the screen is filled with mobs the fps counter goes like a yoyo and it feels really laggy.

Report Forum Post

Report Account:

Report Type

Additional Info