New Ryzen 3700x upgrade 3 times worse performance?

So from

4770k
16gb 2133mhz DDR3
1080ti
(super smooth gameplay) 80~fps pure breach run

to

3700x
16gb 3200mhz DDR4
1080ti
(unplayable fps)5-10 in pure breach run.

other games are fine just poe atm. the game is noticeably not smooth at all.

Anyone have the same issue?
Last bumped on Jul 18, 2019, 10:34:11 AM
I'm getting my 3800x tomorrow. This post worries me. I'll do some testing to see if I run into the same performance problems.
"
I'm getting my 3800x tomorrow. This post worries me. I'll do some testing to see if I run into the same performance problems.


sorry to worry, i'm still testing alot of different settings with bios and stuff. will post back if theres any improvement
I read about Destiny 2 - has also issues. Reinstalling, playing with bios without results.
Last edited by Rexeos on Jul 10, 2019, 2:27:20 PM
Let me know if anyone else gets this behavior. It will be useful to know if others can reproduce this.
Do you have the 1.07.07 chipset driver? Try different power plans?

Great performance with 1700X here...
got the latest drivers, changed ram slots, disabled xmp and entered rated timings. stock voltage, manual voltage, old and new graphics drivers blah blah blah you get the idea.

jump into pure breach 6 man in lowest graphics settings say byebye to fps. literally 10 fps.

tried different power plans in windows and nvidia control panel.

if you are running the game in fullscreen windowed, put a window ontop of the game the fps increased by 30-40 lol.
looks like there is problems with nVidia cards and PCIe 4.0 and that's properly why you have FPS problems right now.

https://www.pcgamesn.com/nvidia/amd-ryzen-3000-bsod-whea-error
Last edited by HanSoloDK on Jul 11, 2019, 12:00:07 PM
Strange thing is, i'm not getting fps problems anywhere else but POE. i asked the 5 other players what kinda FPS they are getting and they said 140+! they all have weaker systems than me.

hope someone internally has the new ryzen and can test it out.
Last edited by ocp15k on Jul 11, 2019, 5:40:36 PM
There is tip to switch PCIE 4.0 to 3.0 - that helped to some people.

https://www.tomshardware.com/news/nvidia-amd-ryzen-3000-bsod-error-fix,39847.html




Its not solution only info. NVidia was able to replicate problem. Problem also affects AMD cards.

https://www.tomshardware.com/news/nvidia-amd-ryzen-3000-bsod-error-fix,39847.html


Last edited by Rexeos on Jul 12, 2019, 6:30:47 AM

Report Forum Post

Report Account:

Report Type

Additional Info