Constant disconnects when loading zones

"
Completed 21 ChallengesSimplyFro wrote:
Have changed Dx version from 11 to 9 and seems it did help.


Same here.
I am having the same issue, long load times and disconnects with new instances since patch. Directx 9 seems to help. Game is pretty much unplayable when its happening.
Same here...
Switching to DX9 and windowed mode seemed to do the trick for me as well. However, DX9 is almost unplayably laggy for me, whereas DX11 seemed to run much better, so I'd still welcome a fix for this problem.
Same here. I have been getting disconnected constantly when loading zones when playing with DX11, but it escalated when I wanted to get to the Ruined Square. I have tried prbbly ten or more times with unexpected DC every time. After I have switched to DX9, it worked all fine.
My usual crash is usually going back to town and the outofmememory siting D11 which I assume is directX 11 related although playing around with settings it does it with D9 as well.

This time I had a hard crash (no error message) in the Labyrinth just fighting a bunch of mobs. I started to lag for about 1 second then crashed. I was almost to the end too :(

The "known issues" solution is very vague regarding the Nvidia drivers. Can anyone give a more detailed answer for a possible solution. I have everything set at the lowest setting except for lighting at medium.
"
Completed 24 Challengesteketoria wrote:
Same thing. Increasing zone loading times (even portal back to town), up to the point of timeout and back to login screen. Didn't have this issue with 2.6. Not really enjoyable.


Friday morning, before the upgrade, I was leveling in dried lake. No problems. Now it's lag and disconnecting constantly. I'm so sad.

Lag is between 3 and 5 seconds, ie, click - four seconds - action.

Friday morning not broken. Now unplayable. I log on to talk to friends who are busy having fun but express their pity. :(
Sometimes… not so simple.
"
undecode wrote:
Using Steam, tried dx9 and disabling engine multithread. Keeps getting stuck at load screen every 2 or 3 maps.
I wanted to play 3.0 but sadly this is unplayeable, around 10 freezes and I'm still level 7...

I'll wait until they release a fix, not going to bother anymore.


Yes. Same.
Sometimes… not so simple.
After about three hours of trying to get the waypoint in The Grand Arena a buddy finally helped me get it. Took three attempts. With his help I got a few more waypoints and I was able to finish act 4. However I am done until this is fixed. I don't want my first experience of the new content to be like the nightmare that was act 3 and 4. Not pissed, just disappointed is all. Wish there was some update on this issue from GGG though.
The same problem here.

Report Forum Post

Report Account:

Report Type

Additional Info