Constant disconnects when loading zones

I can't even load into town. Takes me like 6 tries. Can't change back to direct 9. Game won't even get to load screen before it crashes.
group of 5 long playing friends here and only 1 of us is not crashing on zone change all fixes tried
ggg just dont care. they didnt even make anoun of this problem and fix ETA. they dont care :)
Can we please please please get a fix ???
It is very tiresome
same happens to me. every other zone loading i get kicked to login screen. but i noticed this behaviour only started in the new act 5. acts 1-4 did not have that problem.
Last edited by GDL on Aug 5, 2017, 4:28:43 PM
priima wrote:
i get stuck as well in every single loading screen... still didnt make it out of a1 lol, who they didnt test this in beta? i mean how this did not come up in the beta?

I'm sure most the people in beta had hacked gh performance pcs

But I'm also getting disconnected at load screens. Stuck in A1 rerun Ning content if I'm lucky enough to be able to rejoin before it resets.
Same problem.
Bring back 2.6.

This countinous crash is making me quit
Same thing. Increasing zone loading times (even portal back to town), up to the point of timeout and back to login screen. Didn't have this issue with 2.6. Not really enjoyable.
I also happen to have the same problems, it's honestly quite frustrating.

One thing that has helped multiple people is removing the "--noasync" launch command if you're using it currently.

Unfortunately, I'm not one of the people for whom it worked so I'd welcome any help in the issue.

Report Forum Post

Report Account:

Report Type

Additional Info