Red Elder not giving Memory Fragment

I killed the Red Elder after obtaining the first 14 memory fragments; he proceeded to not drop a memory fragment.

Reference number: 2984259154


Last bumped on Aug 14, 2019, 8:24:46 AM
I have the same issue. Tried it 3 times and he didn't drop it then carried a friend through his red Elder and he instantly got the fragment. There I noticed that every time I killed Elder alone, he didn't explode, he just dropped loot and disappeared, thus Zana was never joining the zone to protect me with the bubble. In my friend's Elder, Zana appeared. Maybe that is where the issue is.

Imgur album with my issue: https://imgur.com/a/mNGYkGN
same problem for me... got the 11-14 fragments but red elder simply didnt drop the 15th.
Bumping this, just had the same issue.
Talking to other people it seems like if shaper dies, the orb will not drop.
This could be intended but I'd like verification in that case!

ref: 2 375 748 511
Just ran another and this time shaper survived, still no memory fragment drop.

ref: 2 965 065 929
Getting the same issue.
Ok, I finally got my fragment, not sure what triggered it dropping this time but what I did was:
Shaper survived
Elder on T15 (Reef), that is not a shaped map (as the tier requirement is supposed to be gone)
Culling strike, to make sure it's not dying from a DoT like some people report problems with.
Same issue

ref: 2 193 772 085
This just happened to me:

Shaper died then I proceeded to kill Elder - Zana didn't appear and no memory fragment dropped.

same here, 2 times

killed elder on t13 and t15 map, no fragment

Report Forum Post

Report Account:

Report Type

Additional Info