"There is a problem with this Windows Installer package." - Fix inside!

Getting the same error as Salre, above, only in English. Also on Windows 10. My log file is the same.

The important part of the log file is:
[30E0:07AC][2016-10-08T17:58:29]i370: Session begin, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{94427be8-df6b-4739-b212-7b285532cfbb}, options: 0x7, disable resume: No
[30E0:07AC][2016-10-08T17:58:29]i000: Caching bundle from: 'C:\Users\###\AppData\Local\Temp\{58EE168C-6684-4900-8FC5-33AEA8B23177}\.be\PathOfExileInstaller.exe' to: 'C:\ProgramData\Package Cache\{94427be8-df6b-4739-b212-7b285532cfbb}\PathOfExileInstaller.exe'
[30E0:07AC][2016-10-08T17:58:29]i320: Registering bundle dependency provider: {94427be8-df6b-4739-b212-7b285532cfbb}, version:
[30E0:07AC][2016-10-08T17:58:29]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{94427be8-df6b-4739-b212-7b285532cfbb}, resume: Active, restart initiated: No, disable resume: No
[3844:3770][2016-10-08T17:58:29]i336: Acquiring container: WixAttachedContainer, copy from: C:\Users\Art\Downloads\PathOfExileInstaller (2).exe
[3844:3770][2016-10-08T17:58:29]i000: Setting string variable 'WixBundleLastUsedSource' to value 'C:\Users\Art\Downloads\'
[30E0:394C][2016-10-08T17:58:29]i305: Verified acquired payload: PathOfExileInstaller.msi at path: C:\ProgramData\Package Cache\.unverified\PathOfExileInstaller.msi, moving to: C:\ProgramData\Package Cache\{90A4562F-D4A1-4B65-906D-41F236CF6902}v2.4.0.64869\PathOfExileInstaller.msi.
[30E0:07AC][2016-10-08T17:58:29]i323: Registering package dependency provider: {90A4562F-D4A1-4B65-906D-41F236CF6902}, version:, package: PathOfExileInstaller.msi
[30E0:07AC][2016-10-08T17:58:29]i301: Applying execute package: PathOfExileInstaller.msi, action: Install, path: C:\ProgramData\Package Cache\{90A4562F-D4A1-4B65-906D-41F236CF6902}v2.4.0.64869\PathOfExileInstaller.msi, arguments: ' ALLUSERS="1" ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" INSTALLDIR="C:\Program Files (x86)\Grinding Gear Games\Path of Exile"'
[30E0:07AC][2016-10-08T17:58:29]e000: Error 0x80070643: Failed to install MSI package.
[30E0:07AC][2016-10-08T17:58:29]e000: Error 0x80070643: Failed to execute MSI package.
[3844:3BAC][2016-10-08T17:58:29]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[3844:3BAC][2016-10-08T17:58:29]i319: Applied execute package: PathOfExileInstaller.msi, result: 0x80070643, restart: None
[3844:3BAC][2016-10-08T17:58:29]e000: Error 0x80070643: Failed to execute MSI package.

I also tried many things mostly along the line of making sure the installation ran as an administrator. The installation seems to begin to have problems at the second line in the log fragment. No directory matching the key in the log "{94427be8..." seems to be created in my "C:\ProgramData\Package Cache" directory. There does not appear to be an .unverified directory there either nor a directory matching the "{90A4562f..." key.

Any ideas would be appreciated.
If you want help, don't necro an ancient thread. Make your own with all of the relevant data that's needed (Check the stickies to make sure you get it all).
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning."

"Your mother was a hamster and your father smelt of elderberries!"
I downloaded the installer off this site and when I try to install it went well but after I open the launcher it says "Disconnected from patching server before patching completed.Try again" :(

Report Forum Post

Report Account:

Report Type

Additional Info