3.18.1c Hotfix

Load time seem to be back to normal for me and the mega stuttering is also gone. (it just stutters like PoE always stutters when you juice up the maps)

I've had one crash to desktop when I gathered up a bunch of mobs and popped pandemonium.

System: Win10, i7 3960X @ 4.2Ghz, 32GB ram, Radeon Vega64 (22.1.2 driver)
PoE is installed on an Intel910 PCIe SSD.
PoE options: DX11, Multithread on, Windowed fullscreen, 2560x1600, VSync off, Foreground fps cap 60, AA off, Shadows+GI (low), Dynamic res off, Dynamic cull on

amd user here, ryzen 1500x and gtx 1060 6gb game is crashing after few minutes every single time
I opened the game today and there was a patch. The first map I played the game crashed without any error message! Yesterday it was fine. Any solution ?
I can't play like this anymore! It keeps crashing every 2-5 minutes, even had multiple crashes in town.
I warned this would happen years ago, now an entire post has complaints. You deserve it ggg.
Im on Series X and since your patch Last night my loading screen was done in a blink of an eye and now is between 6 to 10 sec and sometime up to a full minute.....sometime longer
Rakie1337 wrote:
Crashing every few minutes in maps.

Ryzen 1700x and GTX 1080 here.

From the little I've seen the crashes seems to disproportionately affect combinations of 1st gen ryzen cpus + gtx 10 series gpus.

Exactly what I noticed.

Someone mentioned turning off Multi-threading, that worked fine for me, no more crashes but my comp can't run POE without multithreading...

So they say to get into AMD bios and turn SMT off... And the game will perform better than ever.

How to do that and what it effects I've no damn idea. I'lm currently lookikng into doing that so I can play the damn game tho -_-

You should not disable anything in your bios, they need to revert this crap patch that only made things worse.

Lag and stuttering on a high end pc seems acceptable as they don't even recognize there is a problem with high cpu's and multi threading. Support sends you to the forums and than its dead end.

Getting annoyed now tbh
Last edited by roetetoet on Jul 1, 2022, 10:05:03 PM
After updating the latest patch today, it crashes immediately after entering the game, what is the problem with the CPU? Immediately after that, exit to the desktop and ask customer service for help.

My computer is very old, and I can only use DX11, which is an integrated graphics card of an all-in-one machine. I can play every previous patch update. After the latest patch update, I can't play it.
I mentioned in the post that the game kept on crashing. I looked for a solution and I tried a bunch. The only thing that worked for me was TURNING OFF ENGIN MULTITHREADING, but that made my game almost unplayable with 20 fps. SIGH.

Report Forum Post

Report Account:

Report Type

Additional Info