3.10.2 Patch with Beta of Vulkan Renderer

"
SapphironPL wrote:
Yeah right...
Clicked to switch, bang - crashed...

But... why am i surprised tho...


This is GGG, you will have to wait 5 leagues before they will fix this and 3 leagues before they notice this. :)

Kidding aside, I actually have the same problem with my other PC, a higher end one bought this year. Good thing my 2017 PC works fine, didn't crash on switching and no crash on gameplay so far and seems smooth. Good luck to you man!
Last edited by jmsmadrigal on May 28, 2020, 5:30:29 PM
I've been having stuttering and huge fps drops to 0 on vulkan as well as my game crashing twice during sirus switched to direcxt11 to finish was fine , tried a map with direcxt11 and it seemed unplayable compared to before luckily i can swap back to vulkan and map without crashing just giving this as an update pc is 1070/ 7700k /i7/32 gigs of ram.
Vulkan Renderer, NNidia GeForce 970 GTX, Windowed Mode.... Nice.

Don't stutter when opening Delirium's, don't stutter opening an Abyss, don't stutter opening an Abyss during a Delirium. FPS pretty much stayed 50+ no matter what, and most often was 60+.

Now, initial load from character screen into the game, that needs work. Was a little slow to load MTX. Was a little hilarious running around town with legs and arms exposed as if I had just washed up on the beach, with my helm, chest armor, and back attachment in effect. Eventually the display fixed itself, and didn't really have any issues with zoning afterwards.

So, once optimized, we should have a winner here come 3.11.

P.S. to those that can't switch the renderer. Your video card doesn't support Vulkan.
"
Tidalkraken wrote:
"
MekaDragon wrote:
"
Edgarins29 wrote:
For Linux users on RADV this commit is required to fix the crash:
https://gitlab.freedesktop.org/mesa/mesa/-/commit/d12f2c88427b466aa4944901a700a2d6ecb24a52


Hi! I'm affected by this. How can I apply that commit?


I just tried that new commit but still doesn't work for me under Debian Sid when I tried to switch to Vulkan, the game just close. If I edit the production_config.ini file and manually had the render_type=vulkan, the game open but it close after a few seconds.

Maybe I could test my luck with Ubuntu or Mint however, i'm not a fan of those distro.

@MekaDragon, if you are running a Ubuntu base distribution, the Oibaf PPA has already compile the latest mesa git which include the commit above. You can update your mesa driver from this PPA and it might work.


You can use AMDVLK instead of RADV for now. Just install AMDVLK and add this to your launch options:

VK_ICD_FILENAMES="/usr/share/vulkan/icd.d/amd_icd64.json" %command%
"
MNNoxMortem wrote:
For everyone seeing the greyed out option: Open the options menu from the game menu before you login.


This doesn't actually help for my situation tho :/ and ive heard many others who cannot change the option there either. So doesn't seem the fix for all unfortunately :/

If anybody knows of any other way to fix this I would gladly like to know :)

Edit: Im using Intel(R) core(TM) i3-6100U CPU @ 2.30 GHz, Intel(R) HD Graphics 520

Fearings its my graphic card that is to shite to even use vulcan? :/...

Anyone know if thats the problem and if i wont actually be able to use vulcan?
Mirror Services:
- https://www.pathofexile.com/forum/view-thread/2784962
Last edited by Rai_Grottpojken on May 28, 2020, 6:22:27 PM
it makes the fps really stable for my i9900+radeon RX580 in 2k
with High settings it's 80 steady fps for the legion encounter fog with huge packs, the lowest drop is 50fps
that's pretty cool
Last edited by Danials on May 28, 2020, 7:14:16 PM
"the patch isn't tiny" numbers would be nice.
"



PoE is a great ARPG, but far from being the best by any means.





Which is best arpg? I am genuinely curious.











Last edited by Orbitalx on May 28, 2020, 7:42:52 PM
Tried this out tonight -- Core i7 4790K + RTX 2080 Super.

My initial impression is that things are in fact smoother; my frame rates don't seem especially different in either direction but the stuttering I would see when things appear on the screen seems less.

I'm not sure if the extreme drops I would see in Simulacrum are gone, but I'm cautiously optimistic enough to spend the 300 splinters to find out.

Two things that I noticed:

1) Every time I alt+tab, some sort of device reset happens and the screen goes black for about 2 seconds. Not the end of the world, but I would like it to not happen.

2) When I'm going from one zone to another, the mouse stops responding. The cursor literally stops moving.

All in all, this seems very good to me. Clearly there is some work still to do, but I'm very excited to see it happening.
"
Galtrovan wrote:


P.S. to those that can't switch the renderer. Your video card doesn't support Vulkan.


wrong. i wasnt able to switch over, until i applied the latest graphics drivers released on 5/26.

Thanks for playing.

Report Forum Post

Report Account:

Report Type

Additional Info