3.21.2 Patch Notes (restartless)

Hi Folks,

Don't know if it's right place to write.
After new patch game working significantly worse then before.
I don't have the best configuration but it was working much better.

I5 4690K (overclocked 4.2)
RX 5700 XT
yeah no improvements here and the game is now holding the rest of my pc hostage, i7 6700k & 2060 with 16gigs ram
I do hope the devs see some of these replies. Game is in a significantly worse state post-patch than it was before, and Exilecon is coming up quick. FPS is worse, resource usage much higher, and there's a noticeable stutter now.
This patch makes me believe GGG's lawyers forced Elon Musk to buy POE
nukage wrote:
This patch makes me believe GGG's lawyers forced Elon Musk to buy POE

D4 released their doomed patch at the same time... coincidence?

Csokis wrote:
After mini patch
on linux still not start

2023/07/24 18:41:57 99917155 3cd2cae7 [INFO Client 512] [VULKAN] Init SwapChain = 2560x1371
2023/07/24 18:41:57 99917164 957f12c3 [CRIT Client 512] [VULKAN] unsupported backbuffer image count

I was able to get it running. I edited the config file to change the renderer to DX12 instead of Vulkan. It still immediately crashes if you try to switch back to Vulkan once in-game, but performance seems ok using DX12 for now.
Last edited by woodsofypres on Jul 24, 2023, 6:34:34 PM
Thanks for destroying the game. FPS dropped by half.

My build
RTX 3070
Just logged in, went outside of town and it didn't seem worse (maybe only initially? actually I kinda forgot), opened a T16 rare Strand map with a Delirium mirror and yeah frame drops were quite big although not so big that I'd die, still very bad though, obviously in the realm of "critical bug" if every player gets this all the time. Then I turned on triple buffering and did another T16 Strand map with a Delirium mirror, fps was still dropping a lot, maybe a bit less than before. The game was very much willing to go to pixellated mode.

On the plus side, things seemed better looking? Though I haven't played in 2-3 weeks so I'm not sure.

I'm using nvidia 1050 ti (low end GPU) and intel i9 9900k (powerful 8-core CPU). My in-game settings are all graphics to lowest, directx 11, didn't try changing to vulkan. Anyway I only logged in to check how this patch affects things.

So I didn't want to do 10 more Strand maps to check whether this will go away once my system gets some time with this new patch (assuming it was just doing expensive one-off preloading), or if it'll be like this until they fix it. I'm pretty optimistic that there will be a fix by 3.22 launch.
I just wanted to report that before the patch I got 60 fps (frame capped lol)

After the patch I still get 60 fps. No issues whatsoever.
Most graphic settings are on highest.

CPU: 11900k
GPU: RTX 3060 (12GB)
Memory: 128GB (not a typo)
Primary Disk: SSD Evo 870 1TB
Monitor resolution: 4K


fwiw I don't have PoE connected to Steam.
From South Africa, recently moved to England. Player since closed beta 2012. Full system specs: https://pastebin.com/yDHYXWJT
'Tongueslurp the Unspeakable' - skeleton archer in Fellshrine Merciless
Last edited by Zedda on Jul 24, 2023, 7:08:26 PM
literally cannot play anymore since update....

Report Forum Post

Report Account:

Report Type

Additional Info