3.10.2 Patch with Beta of Vulkan Renderer

lab ladder prize rework when?
Harvest Master Craft Service in Harvest My IGN TreeOfDead
https://www.pathofexile.com/forum/view-thread/2037371 Vouch
Harvest Masters 8 level Crafting All Service all crafts mods
Best Harvest SC Master Craft Service Harvest SC in HSC craft!
Master Crafting Service in Harvest HSC PM: TreeOfDead
"
LengaJenga wrote:
Can't change the renderer option to Vulkan. The option is grayed out.
I even tried forcing the game to run in Vulkan through the config file, but it would just change back automatically on launch. I am attempting to change the option on the main login screen too, NOT in-game.

-Windows 10
-GTX 1060 3gb
-Drivers updated to 446.14 (05/27/2020)

DXDIAG - https://pastebin.com/xnPfeXGy


Same here. Renderer option is disabled

GTX 1080
Windows 10
Last edited by babutian on May 28, 2020, 2:38:08 PM
Edit: images did not embed, removed them.

tl;tr: PoE Delirium was so unplayable for me it sucked out all fun. Vulkan lowered the FPS from 145 peak (60 average) to 80 peak (50 average) but I have no spikes anymore. Thank you so much! The most critical scenarios: Metamorph fights and delirium now peak out at about 36ms which peaked for over 1000ms before.

Nvidia Geforce GTX 1080 TI
AMD Ryzen Threadripper 1900X 8-Core
64GB G.Skill Ripjaw V
Installed on a Samsung 970 Evo Plus
Last edited by MNNoxMortem on May 28, 2020, 2:56:23 PM
Same here the option is not available,

Imac intel I5-4690
win 10
radeon 290 X

waitting the patch of the patch
My pc showing gpu useage between 90-100% when running. Tried to switch to vulcan and crashes my game client.
For everyone seeing the greyed out option: Open the options menu from the game menu before you login.
"
coyd wrote:
"
HazaRdReborN wrote:
Guys, some of you with issues. Just post your gpu or something too. Some of you just saying it doesn't work isnt really that helpful yo xD


Exactly its like sayin my car doesnt work whats wrong with it ? It can be its out of fuel to dead engine you know :D


pretty much xD
"
MekaDragon wrote:
"
Edgarins29 wrote:
For Linux users on RADV this commit is required to fix the crash:
https://gitlab.freedesktop.org/mesa/mesa/-/commit/d12f2c88427b466aa4944901a700a2d6ecb24a52


Hi! I'm affected by this. How can I apply that commit?


I just tried that new commit but still doesn't work for me under Debian Sid when I tried to switch to Vulkan, the game just close. If I edit the production_config.ini file and manually had the render_type=vulkan, the game open but it close after a few seconds.

Maybe I could test my luck with Ubuntu or Mint however, i'm not a fan of those distro.

@MekaDragon, if you are running a Ubuntu base distribution, the Oibaf PPA has already compile the latest mesa git which include the commit above. You can update your mesa driver from this PPA and it might work.
Yes, you need to be on the login page to change it.
I've tried it and it feels awesome. So much more smooth, feels so much better. More fps and no stuttering with mobs all over the screen. Tradecompanion doesn't work tho and same with trademacro. But I guess that can be expected.


i7-9700K 5GHz
16 RAM
RTX 2070
144 Hz
nvme ssd
Got myself a RAID!

PoE 4.0.0, HYPED!
Here's my feedback with Vulcan.

Laptop goes vroooooooommmmmm

Game freezes.

Game crashes.

:(

Report Forum Post

Report Account:

Report Type

Additional Info