[Tool] POE Trades Companion - Enhance your trading experience (v1.12.3)

"
Completed 37 Challengesephilios wrote:
sorry for late reply

Spoiler

[PROGRAM]
FileName=POE Keyword Notifier.ahk
Last_Update_Check=20180101163812
PID=4832
Version=0.2.1
[BUTTONS]
Button_1_Message="@%player% Hi. Invite, please?"
Button_1_Name=Hicust
Button_2_Message="@%player% Hi. Invite, please?"
Button_2_Name=Threadreply
Button_3_Message="/invite %player%"
Button_3_Name=Invite
[SETTINGS]
Auto_Update=1
Timer_Keywords=30000
Timer_Logs=600
Transparency=200

I'll be updating the Keyword Notifier tool so that it makes use of the Clipboard. This will fix the strange "space" issue you are getting.

"
Completed 9 ChallengesRonthCole wrote:
"
Completed 11 Challengesz0rhawk wrote:

"
Completed 9 ChallengesRonthCole wrote:
Just installed latest beta. It now appears at all times, even when "only show while in game" is checked.
Seems to be working just fine for me. I haven't made any change regarding this either.
Can you confirm that it works fine after reverting back to the previous version? Don't forget to disable the auto-updating setting, in the "About?" tray menu.


I reverted back to 1.12 and the blue banner still appears in the upper right-hand corner even when POE is closed. Closed and restarted POE Trades Companion, same thing is happening.
There was an issue where the tool would still appear when on the desktop. I have made a fix for that, but still haven't released a new version for it. This should potentially fix your issue.

"
Hey z0rhawk, I have my own script that I run to do some minor things. One of those things is opening a portal scroll. I have noticed that when I load your script alongside mine that my script seems to move slower than when I am not using your script. I never noticed this with past versions of trade-companion.

I can tell it is slower because I can see my mouse move to the portal scroll. Granted it moves fast but without trades-companion running that movement is near instant.

Would you know of anything I could do to fix this issue? I have all the hotkeys disabled in trades-companion.

thanks.
Hey there,
Try improving the speed of your script:
"
SetDefaultMouseSpeed, 0
Alternatively, try SetMouseDelay, -1

#NoEnv
SetBatchLines -1
ListLines Off
Perfect sir ! Big thx
All in one service, masters 8 and boss service
Master Craft Service in BESTIARY SC. My IGN: Ephiservice
Free Maps/Challenges/Shaper/Breachlords/Guardians/Uberlab/Atziri service
Main and vouch thread : https://www.pathofexile.com/forum/view-thread/1975446
"
Completed 37 Challengesephilios wrote:
Perfect sir ! Big thx
The Keyword Notifier update has been released a few hours ago.
The tool should prompt you to update on next launch.


Update%20Released

Updates v1.12.1 & 1.12.2 have been released: Release notes

Changes:
  • The "Clipboard item" function now use "l: x" and "y: +x%" instead of "level: x" and "quality: +x%" for gems.
    This was done to reduce the characters used in the search string.
  • When updating with the "Enable BETA" setting enabled", if the release on "stable" is "better", it will choose that one instead.

Fixes:
  • (1.12.2) A "new update available" notification would always appear on start.
    This bug was caused by the recent updating changes brought with 1.12.1.
  • Having the "Only show while in game" setting enabled, the tool would still show on certain windows (such as the desktop)
  • Some items could not be pasted into the in-game stash search.
    This was due to the in-game stash search having a limit of 50 characters.
    Any item past the length will have its name cut to fit.
"
Completed 11 Challengesz0rhawk wrote:

"
Hey z0rhawk, I have my own script that I run to do some minor things. One of those things is opening a portal scroll. I have noticed that when I load your script alongside mine that my script seems to move slower than when I am not using your script. I never noticed this with past versions of trade-companion.

I can tell it is slower because I can see my mouse move to the portal scroll. Granted it moves fast but without trades-companion running that movement is near instant.

Would you know of anything I could do to fix this issue? I have all the hotkeys disabled in trades-companion.

thanks.
Hey there,
Try improving the speed of your script:
"
SetDefaultMouseSpeed, 0
Alternatively, try SetMouseDelay, -1

#NoEnv
SetBatchLines -1
ListLines Off


SetDefaultMouseSpeed did the trick. ty
Hey everyone,

I have just made another tool: POETrade Instant Whisper (GitHub Repo):
  • Save time by instantly sending a poe.trade or poeapp whisper.
    Simply hold down the CTRL key when clicking on "Whisper".

It was supposed to be for private usage at first, but I figured it could be useful for others sooo here it is! It really helps when trying to buy items and sellers are ignoring your whispers.
It saves you a total of 6 inputs (Alt+Tab Enter CTRL+V Enter)

Normally, you have to tab out of game to copy the whisper, then tab back in to send the whisper. With this tool, you can simply hold CTRL when clicking on the "Whisper" link from poetrade/poeapp.

At the moment, it does not allow to automatically tab back on your browser.
Though I may add it later on (probably as CTRL+SHIFT).

POETrade Instant Whisper repository on GitHub
Sometimes when i use the "Clipboard Item" button i have to delete the "" and the Tier:X before it actually finds the item otherwise nothing comes up... anyone know why?
"
Completed 7 Challengesherreppe wrote:
Sometimes when i use the "Clipboard Item" button i have to delete the "" and the Tier:X before it actually finds the item otherwise nothing comes up... anyone know why?
It's most likely because rare maps have their name split on two lines, so the literal quoted search doesn't work like it should.

Magic map, searching "Zana's Jungle Valley Map of Deadliness" will work. 3EAUoR6

Rare map, searching "Forgotten Zone Arena Map" will not work because the liens are split.O1NEDFp

The tier:XX issue could be due to a bug in the game where Shaped maps do not have their internal tier updated (Example: a shaped T8 map can only be found using tier:8 when it should appear as tier:13). The workaround is to search for tier text that is written on the map infos: "Tier: XX".

Thank you for letting me know, I'll be releasing an updating to include those changes!
"
Completed 11 Challengesz0rhawk wrote:
"
Completed 37 Challengesephilios wrote:
sorry for late reply

Spoiler

[PROGRAM]
FileName=POE Keyword Notifier.ahk
Last_Update_Check=20180101163812
PID=4832
Version=0.2.1
[BUTTONS]
Button_1_Message="@%player% Hi. Invite, please?"
Button_1_Name=Hicust
Button_2_Message="@%player% Hi. Invite, please?"
Button_2_Name=Threadreply
Button_3_Message="/invite %player%"
Button_3_Name=Invite
[SETTINGS]
Auto_Update=1
Timer_Keywords=30000
Timer_Logs=600
Transparency=200

I'll be updating the Keyword Notifier tool so that it makes use of the Clipboard. This will fix the strange "space" issue you are getting.



Hi sir i was preparing the notifier tool for next league i have the same problem with space :(


Preferences :
[PROGRAM]
FileName=POE Keyword Notifier.exe
Last_Update_Check=20180220205112
PID=6672
Version=0.3
[BUTTONS]
Button_1_Message="@%player% Hi sir , i will be avalaible in few seconds. Dont forget to reply my thread after my craft / service !"
Button_1_Name= Avalaible
Button_2_Message="/invite %player%"
Button_2_Name=Invite
Button_3_Message="@%player% Thanks sir , i'd appreciate if you could reply my thread which is ID:1975446 ! Have a nice day sir ! :)"
Button_3_Name=Bye
[SETTINGS]
Auto_Update=1
Timer_Keywords=30000
Timer_Logs=600
Transparency=200


Screen of the space bug before name :
3HCqdRq
All in one service, masters 8 and boss service
Master Craft Service in BESTIARY SC. My IGN: Ephiservice
Free Maps/Challenges/Shaper/Breachlords/Guardians/Uberlab/Atziri service
Main and vouch thread : https://www.pathofexile.com/forum/view-thread/1975446
Last edited by ephilios on Feb 20, 2018 3:01:39 PM
"
Completed 37 Challengesephilios wrote:
Spoiler
"
Completed 11 Challengesz0rhawk wrote:
"
Completed 37 Challengesephilios wrote:
sorry for late reply

Spoiler

[PROGRAM]
FileName=POE Keyword Notifier.ahk
Last_Update_Check=20180101163812
PID=4832
Version=0.2.1
[BUTTONS]
Button_1_Message="@%player% Hi. Invite, please?"
Button_1_Name=Hicust
Button_2_Message="@%player% Hi. Invite, please?"
Button_2_Name=Threadreply
Button_3_Message="/invite %player%"
Button_3_Name=Invite
[SETTINGS]
Auto_Update=1
Timer_Keywords=30000
Timer_Logs=600
Transparency=200

I'll be updating the Keyword Notifier tool so that it makes use of the Clipboard. This will fix the strange "space" issue you are getting.



Hi sir i was preparing the notifier tool for next league i have the same problem with space :(


Preferences :
[PROGRAM]
FileName=POE Keyword Notifier.exe
Last_Update_Check=20180220205112
PID=6672
Version=0.3
[BUTTONS]
Button_1_Message="@%player% Hi sir , i will be avalaible in few seconds. Dont forget to reply my thread after my craft / service !"
Button_1_Name= Avalaible
Button_2_Message="/invite %player%"
Button_2_Name=Invite
Button_3_Message="@%player% Thanks sir , i'd appreciate if you could reply my thread which is ID:1975446 ! Have a nice day sir ! :)"
Button_3_Name=Bye
[SETTINGS]
Auto_Update=1
Timer_Keywords=30000
Timer_Logs=600
Transparency=200


Screen of the space bug before name :
3HCqdRq
Hi there,

Do you use POE Trades Companion as well? If so, do you ever have that issue with it?
If you do have the same issue, then what is your keyboard layout as it is set in Windows?
Also, what is your key to open the chat window in-game?

To me, it looks like the space between @ and the player name is actually part of the %player% variable. Could you try this version here and tell me how it goes?
"
Do you use POE Trades Companion as well? If so, do you ever have that issue with it?
If you do have the same issue, then what is your keyboard layout as it is set in Windows?
Also, what is your key to open the chat window in-game?

To me, it looks like the space between @ and the player name is actually part of the %player% variable. Could you try this version here and tell me how it goes?



Its working but the @From check dont working , only on globalchat or tradechat scan work
All in one service, masters 8 and boss service
Master Craft Service in BESTIARY SC. My IGN: Ephiservice
Free Maps/Challenges/Shaper/Breachlords/Guardians/Uberlab/Atziri service
Main and vouch thread : https://www.pathofexile.com/forum/view-thread/1975446
Last edited by ephilios on Feb 24, 2018 4:21:30 AM

Report Forum Post

Report Account:

Report Type

Additional Info