[Steam] "There has been a patch that you need to update to"

Every time I try to launch the game via steam, when I go to log in I get the error "there has been a patch that you need to update to. Please restart Path of Exile." When I close the client, Steam starts to download a new patch. When it is done, and I launch the game, I get the same error when I try to login. Steam then tries to download a new patch again when I close. Repeat, over and over.

I have tried uninstalling and reinstalling the game. I have tried verifying the integrity of the game cache. Same issue. It does not matter if I use the PathOfExile_x64Steam.exe or PathOfExileSteam.exe. Nothing I seem to do will let me in. It seems to just not be applying the patch.

Any assistance would be appreciated. Thanks.
Last bumped on Feb 25, 2021, 8:50:49 PM
Same issue. Applying a non-existing patch each relaunch.
BUMP - I have the exact same issue. Every time I try to load the game it takes 30 minutes because of this !
Hi there, Exiles!

Can you please reboot your system and try to run Steam and Path of Exile as Administrator to see if this resolves the issue?

Need help? Contact us at support@grindinggear.com :)
I have the same issue as OP since yesterday except i' running the standalone client. uninstalled reinstalled and rebooted my system. no change.

two things to note:
1- If I keep pressing ok and try again it eventually goes through...
2- I seem to only get the error when I select Canada/East gateway, DC appears to be working fine.
Hi there, h3dges!
I'm afraid that it is difficult to troubleshoot multiple player's individual situations in one thread. If you would like further help with your specific issue, can you please post a new thread with a description of what is happening for you in particular? Thank you!
Need help? Contact us at support@grindinggear.com :)
Same for me and I also play in Canada server.


Edit: I have the same fake update when I start the game.
Last edited by Tigritan on Feb 24, 2021, 5:58:07 AM
I also can confirm, ever since the most recent patch, I get the same notification when I try to login to Canada East. Then I close the game and click Play from Steam and I download this really long update that I obviously don't need, then the game works. Normally updates in Steam take under a minute with the changes GGG made at the start of Heist league. I wonder if it's Canada East related as mentioned above. Strange choosing that specific gateway would trigger this loop though.

Edit: the person above me is correct, this only happens when trying to login to the Canada East gateway. No issue whatsoever on DC. You can force click login and eventually Canada East will work, but when you close the game you'll have to do the update within Steam which is clearly not worth it.
Last edited by ElSpeerzo on Feb 24, 2021, 12:25:54 AM
Heyo.

Reinstalled. Ran both as admin. Problem still persists but only on Canada East as others have mentioned
Same. Can east.

Report Forum Post

Report Account:

Report Type

Additional Info