Terrible stuttering and bad allocation error

Hi! I'm having some terrible stuttering at certain momments in the game, especially in Act 2 with all the monkeys and other monsters or when I use some skills with my witch (for example, when I summon skeletons, the first two skeletons I summon will stutter the game).

I'm playing the game in a laptop, 800x600, windowed mode, no shadows, antianalizing off, trilinear filtering, VSync off, Post proccesing off, screen shake off.
(I'm playing with sound; no idea if that has anything to do with anything)

My computer specs are:
AMD Athlon 64 x2 processor L310 (1.20GHz)
ATI Radeon HD3200 Graphics
2 GB Memory

ALSO, when I was loading a map of Act 2 an error occurred that said "bad allocation" and then the game stoped working and shut down.

Any suggestions?
Thanks in advance!
Last edited by Sere312 on June 29, 2012 8:28 PM
Anyone there? Any answers? anyone? :/
The skill stutter problem when you first use skills is because we're not yet able to preload some of the effects they use (The glow of the skeletons, for example). If it is very slow on your PC, I'd suggest just casting the skills when you first start the game - They should be loaded into memory for the rest of your session.

As for the "Bad Allocation", is this something that happens a lot? You can try running the Pack Check and removing any corrupted files.
Balance & Design
Need Support? support@grindinggear.com
So the skill stutter won't be there forever? great! :D
I used the PackCheck and no error came up (and so the launcher didn't repatch anything), but also when I went into the map where the "Bad Allocation" error appeared it didn't this time, so I don't think it was a problem with the game...

Thanks! :D

(also, does playing the game with sound make it go slower or can I play it with it and don't worry about it? If it does I would suggest a button to disable all sound :P)

Also I have seen that the "Client" log (in "Logs" folder) keeps track of everything ever said in the chat. Doesn't this slow down the game?
Last edited by Sere312 on July 2, 2012 5:38 PM
At the moment you can add --nosound to the end of your Path of Exile shortcut if you want to disable sound entirely - Though reducing the volume sliders to 0 should do this. I'll have to confirm that though!

The client log file might only cause problems if the file is very very large - Writing there shouldn't cause any noticeable delay.
Balance & Design
Need Support? support@grindinggear.com
yes i would watch ur client data i tend to delete mine when it hits 5mb. recently i noticed it was at 32 mbs!!! i was like woah. lol but deleting it will simply erase that for ya.
"
Rory wrote:
At the moment you can add --nosound to the end of your Path of Exile shortcut if you want to disable sound entirely - Though reducing the volume sliders to 0 should do this. I'll have to confirm that though!

The client log file might only cause problems if the file is very very large - Writing there shouldn't cause any noticeable delay.


Yes, but it would be nice to have a button to disable all sound without reducing the volume sliders, so that then when you want to play with sound you just have to press the button again instead of trying to configure the sliders to where they were before :P

Thanks for the support! :D
I'm having troubles in Dark Forest, Act 2. When I entered that area for the first time I had Unable to map file, and for the second time Bad allocation error appeared.
Antialiasing - off
anisotropic filtering - off
V-sync - off
resolution 1280 X 800
Everything else on maximum.
nVidia 9600m GT 512 MB.
Ivor "Jesus" Ježabek
"
Jesus666 wrote:
I'm having troubles in Dark Forest, Act 2. When I entered that area for the first time I had Unable to map file, and for the second time Bad allocation error appeared.
Antialiasing - off
anisotropic filtering - off
V-sync - off
resolution 1280 X 800
Everything else on maximum.
nVidia 9600m GT 512 MB.


Same problem here, I crash very often when loading new areas maybe around 10-20%. Says either unable to map file or bad allocation. Affects all areas. Iv run the packcheck but without any results.

I run 2x AA
8x AF
fullscreen mode
VSYNC
everything else maxed out

Windows 7 Ultimate 32-bit
Radeon HD6870
PhenomII X4 965 3,6 Ghz
4Gb A-Data Gaming Series 1666Mhz CL9
GIGABYTE MA770-UD3
SSD OCZ Agility 4
all on default settings


thx for acknowledging



IGN: ISmellSomthinBurnin
Last edited by OldSurehand on August 15, 2012 10:25 AM
I have the suspect that this "bad allocation" error is somehow related to the "unable to map file error"
I've had both, they both appear in the same situations, while loading a map. And they are both solved by just disabling the sound of the game.
It's kind of annoying having to play without sound, but it's something that ensures me a safe game.
Hope any of this data can help you to get this error fixed as soon as possible.

Thanks for the work ggg!

Report Forum Post

Report Account:

Report Type

Additional Info