2.5.2d Patch Notes

"Patch 2.5.2c
Fixed performance issues with DirectX 11 affecting some users, that were introduced in 2.5.2.

Patch 2.5.2d
Fixed a bug where textures could fail to load and cause a device error."

I was affected by both of these - nice to see that stuff fixed.
Here's an example how stuff looked like straight after 2.5.2.

I hope that weren't preparations for cinematic 30fps on minimal settings on Xbox.
Last edited by Jansos on Jan 27, 2017 6:23:51 AM
Ummmm....

This is concerning, please could you fix the known performance issues that arose due to patch 2.5.2, especially 2.5.2c "performance patch" as well?

https://www.reddit.com/r/pathofexile/comments/5q78tp/patch_notes_252c/?sort=new

https://www.pathofexile.com/forum/view-thread/1825254

https://www.pathofexile.com/forum/view-thread/1824387/page/1#p14141496

https://www.reddit.com/r/pathofexile/comments/5qb9aa/psa_discussing_performance_issues_always_mention/

Thanks!
Last edited by Bhaladas on Jan 27, 2017 6:30:24 AM
Did they actually revert the patch because I am now crashing on DX 11 where I was not before.

No error message, just drops to desktop.
I'm currently scared to update to 2.5.2D... i dont want to re-download the game if the patch corrupt it .. :(

Edit : ( Those fix are like Vaal Orbs :D )
Last edited by Criitik on Jan 27, 2017 9:23:34 AM
"
Completed 38 Challengesosna23 wrote:
i still get game crashes when i use 'exit to character selection'.
been like that for some time now


+1.

Only happens when im in my hideout with map portals opened
Last edited by rdyBeta on Jan 27, 2017 10:43:24 AM
No UI after 2.5.2b, no UI after 2.5.c and no UI after 2.5.2d. I dont know if it's fixed for others, probably not... Error 740 while trying to switch to DX11. Before that I need to spam minimize/maximize and alt+enter to eventually get UI. Please fix!
for now didnt get d3d9 shader error but game laags like hell.....


laggg
Last edited by Rafix123 on Jan 27, 2017 6:40:59 PM
I'm still getting the same error as before and it reads like this:

in source code file..\device\d3d9\deviced3d9.cpp at line 198
error processing file
error d3derr_invalidcall
failed to create device

(all letters caps tho, feeling too lazy to keep shifting lol)


am i going to have to reinstall game now?
Last edited by bigcat25 on Jan 27, 2017 10:37:55 PM
SK7tDpN
ZiggyD is the Labyrinth of streamers, some like it, some dont, but GGG will make sure to push it down ur throat to make you like it
can someone help me with these missing files :


2017/01/28 12:19:51 4835640 10f [DEBUG Client 5848] [WARMUP READ] Cannot find resource file: ast_table
2017/01/28 12:19:51 4835640 10f [DEBUG Client 5848] [WARMUP READ] Cannot find resource file: sm_table

they are the reason i cant play the game since 2.5.2
Ign: ThatManWithTheBow

Report Forum Post

Report Account:

Report Type

Additional Info