3.22.2 Patch Notes

Micro24 wrote:
Performance is better after this patch. For my case, DX12 renderer is the most consistent in performance. DX11, after all the caching, is not as performant as DX12. Lower frame rates and lower fps consistency. Vulkan renderer, after its caching, is a lot better than DX11 for consistency, but lower max fps which is a trade-off much better than inconsistent fps.

Channel count on sound setting is set to Low.

My graphical settings are set in its lowest setting except:
- Resolution = 1920x1080 (Native) borderless windowed
- Renderer: DX12
- VSync: Off
- Triple-Buffering: Disabled
- Bloom: 75%
- Water Detail: High
- Texture Quality: High
- Texture Filtering: 16x
- Dynamic Culling: Enabled
- Dynamic Resolution: Enabled
- Target Framerate: 48
- Engine Multithreading: Enabled

OS: Arch Linux x86_64
CPU: Intel I5-12400
GPU: AMD Radeon RX 6600 (8GB)
Memory: 16GB
Steam Linux Client
Proton Version: 7.0.6

Can I ask you why Proton 7.0.6?
Does it have something special?
Or it's just "do not touch what is working?"
What's your GPU/CPU latency according to ingame graph? and fps.
But most importantly WHY 75% BLOOM????? :D
Last edited by gorioo on Oct 25, 2023, 3:11:40 PM
Time to start grabbing resources from PoE 2 and fix THIS game FIRST! Every patch you release causes more and more issues! Oh and I almost forgot, once I ACTUALLY get into the game, I have to wait longer for JUST the map tab to update with maps....its an empty tab with no maps and just a solid box now....Wasn't like that before the patch.......and once again, after a map I go to my map tab and its EMPTY AGAIN!!!
Last edited by IQof3 on Oct 25, 2023, 5:55:25 PM
wth is wrong with this patch. i cant even see shit. monsters are invisible
gorioo wrote:

Holly crap.
What hardware do you have?
And did you try to change renderers?

My specs are really outdated, yeah. But before patch I would have 30-ish fps in my hideout and 50-60 in maps without heavy load (which in case of poe somehow might be a single rare mob casting invul aura just for the sake of it), not 18 everywhere with changing half of my setting to higher and back (except turning off multithreading, it lowers fps to ~10). I'm using DX11, because Vulkan has a bad property to kill my voice in Discord voice channel when I experience too much "fun" in maps, and I have constantly re-enter the channel to fix it. This actually started to happen with DX11 rarely after the pre-league patch, and I haven't tried Vulkan for long this league (Ran some maps and other content with it early to confirm it also loading shaders all the time and re-loading them for minute every time you enter the map, no matter same of new; also it was covering TotA floors in soap which I didn't like at all). DX12 before pre-league patch was quite unplayable for my old PC, making everything much worse, I think I also tried it before to make sure it doesn't fix shaders problem as well.

Weird thing about this all - I do not have any longer loading times like a lot of people have after the patch. Also after restarting the game it remembers to use dynamic resolution for awhile, then forgets how to do it again:)
After the patch my animated guardian shows only his sword and mask o.O
Improved dynamic resolution to avoid jarring situations where the resolution scales down and up in quick succession.

So after the patch, I had no dynamic resolution applying at all. And later when I returned to play a bit more it was there again, and the game was smooth for a few maps, then its gone again and do not come back anymore. I mean I literally have 18 fps staying in empty map, and with target fps at 50 I can disable/enable dynamic reso with no change whatsoever. Did you do the delay between scaling resolution in hours, or what?:)
As of why I have 18 fps in the empty map after the patch - I've no idea.

I've had the exact same experience. It was running really nice and smooth for a bit but now I am sitting at 20fps even in hideout and it's obviously far worse in map.

I'll try adjust some settings tomorrow but it's pretty annoying. It was so nice when it was running correctly. At least this seems to confirm it's not the hardware but something wrong with the game.
It's impressive how these performance and loading patches never fail to make things worse. Don't think I've ever seen invisible enemies in Blood Aqueduct or invisible plants in Harvest before. Yeah, the Harvest floor's been blue tiles for awhile, but after this patch they're blue tiles for longer alongside plants that take a bit to show up. Fun! You'd think that texture-loading issues would be a thing of the distance past with textures being a solved problem in the gaming world for 20 years or so and SSDs being so ubiquitous...
Last edited by Futchya on Oct 25, 2023, 11:24:07 PM

My specs are really outdated, yeah.

So what they are? :D just curious.

because Vulkan has a bad property to kill my voice in Discord voice channel when I experience too much "fun" in maps, and I have constantly re-enter the channel to fix it. This actually started to happen with DX11 rarely after the pre-league patch

Maybe try to disable hardware acceleration in Discord? Idk if it will help but hw acceleration means discord uses gpu.
Just opened Steam and saw a little Update downloading for PoE. I thought: Okay, they started fixing this mess of a patch. 2 mins to load into town, go to Blood Aqueducts, wait another 2 Minutes just to watch my whole System freeze up before the game crashes. Well done!
Confirming LONGER load times since patch, longer invisible entities, incursions which are practically completely unrendered long enough to nearly lose a trip to time limit or death...

Stuttering (c-state/multi-threading fail) still there, low FPS, sound still cuts out when things start getting busy, but most of that's been there for years - just worse every patch.

Report Forum Post

Report Account:

Report Type

Additional Info