3.21.2b Patch Notes


I fixed all issues with this game, after upgrading my pc.
To be honest only thing that matters rn is how much RAM you have.
This game can eat 8GB of normal RAM.
Idk if GGG put some sort of 4k or 8k textures or something.
But now RAM usage went from comfy 3-4gb to 8gb.
And I'm still at lowest settings possible.
To be honest this is only game on my pc now that needs so much ram.
Unfortunately, it seems that the visual bugs caused by Syndicate (most notably when exiting a Research encounter and during the Catarina fight) are still present, despite deleting the shader cache folders, updating my graphics drivers to the latest version and tweaking the in-game settings to see if there will be any difference.

As per the above, we can rule out corrupted shader cache as the reason for this problem. And just to add something else I forgot to mention in my last post, simply alt tabbing the game can cause very similar random visual bugs as well (more often in Fullscreen mode, while Windowed Fullscreen seems to have better stability for me), so there is definitely something wrong with the game at the moment.
May I ask what you updated? Is your update to make the gaming experience worse?
It takes almost half a minute for me to enter the game or change characters now
Alchemy0412 wrote:
Ok so, why is poe using 9 gigs of my vram?

I have the opposite problem, the game doesn't seem to use more than 20% of my available vram ever, and it's not a new rig at all. Massive stutters all over the place, even when entering the same map again after dying and when 90% of the mobs are already dead.

VAD_e wrote:
Unfortunately, ...., so there is definitely something wrong with the game at the moment.

I've been doing a lot of Syndicate lately trying to burn through Jun missions and I didn't get those glitches. I assume you mean the khaki-coloured things? If so, that might be something on your end after all. I did 3 Catarina's today and didn't see anything like that.
The end is nigh
Last edited by Hosshiun on Jul 29, 2023, 1:56:48 PM
ziipher wrote:
For those having trouble moving over to the technical support side of this forum, here is some helpful information.


This post explains how he fixed his game. It removed the studdering, and also can remove some visual bugs that most likely happened when the most recent patch dropped on Monday.

Clear your client's cache
If any cached client data has become corrupted it could also cause a variety of problems, from visual anomalies to crashes.

To clear your client's cache, go to %AppData%\Path of Exile on your computer and delete the cache folders.

Clearing your client's cache will clear out several temporary storage locations that Path of Exile uses for things like downloaded images and graphics shaders. After clearing cached shaders your client performance will be temporarily degraded while the client regenerates the shaders it needs. For this reason we recommend only clearing your client's cache as a last resort when troubleshooting a crash or other graphical problem, or if the size of the caches has become a problem.

This is not working. I'm running the same 2 maps. Every single encounter still stutters after 2 hours. Back to Vulkan with invisible mobs and effects. Fun!!!

Last edited by greatwhitepine on Jul 29, 2023, 2:38:59 PM
Followed Tech Support general guidelines and did all steps.

Game runs a bit smoother.

It still runs smooth, but ramps up gpu/cpu on stacked essences or big packs... where it never used to before the change.

Biggest complaint now though... is the random crashes. In the hideout mainly. If I mess around in my stash for a while crafting or just sitting idle for a few minutes, game just crashes for no reason.
I hope this was not the last patch for this messy engine state. I still can't delve, because the game crashes when I zoom out the map and the game still stutters more than before and uses way more resources.

Ryzen 9 5950 X
RTX 3060 Ti
64 GBs of RAM
Samsung SSD 980 PRO 1TB
I noticed that each time I log in, the shaders bar goes to full for maybe a minute or two, in town. You would think that it's compiling the shaders right?

but when the shader bar goes empty and I re-enter the town it goes back to full again (for as long as the first time).

Why would it have to compile shaders (like it's the first time) each time I go back to town?

I think I found the source of the problem. It wasn't poe's cache folders, but Nvidia's shader cache folders instead.
Check your Nvidia control panel settings and see what's the shader cache folder size limit (increase it if you can). Also, check the folder's size on your computer.

for example, you might have the max cache folder size set to 4gb and the folder be full, so it will have to constantly delete older files to make space for the new ones.

And by the way, I found files in my Nvidia's cache folder dating back to the exact day I started playing poe (those are all from before the patch and could be causing problems but I'm not sure).

BUT... as a precaution, don't delete anything from Nvidia's cache folders. Just move them elsewhere and test if things get better.

After I cleared the Nvidia cache folder, My shader bar would no longer stay at full each time I go back to town, but it has caused a few stutters which I think could be related to the lack of any cached shaders on my system which should technically go away the more I play.

The default path for the Nvidia shader cache folder should be something like:


Edit: this only shortened loading/shader compiling times, the stutters remain as before
Last edited by Zenthon74 on Jul 30, 2023, 3:41:25 AM
>go to subterranean encampment
>open map
>scroll out 7 notches
>everything's good
>scroll 8th notch out
>game crashes
repeatable. unforgivable.
I still can't delve, because the game crashes when I zoom out the map

On my Nvidia 4060, the game crashes when I zoom out while using the DirectX11 renderer. Switching to the DirectX12 renderer stops the crashing, though the Delve chart gets glitchy when zoomed out all the way. Vulkan had none of those problems with the Delve chart, but FPS in the game even in hideout was very choppy so I switched back to DirectX12 (which is what I always use anyway) and I simply don't zoom the chart out.

Report Forum Post

Report Account:

Report Type

Additional Info