3.13.1e Patch Notes

Not sure if true but it seems this patch has improved my performance. I am currently playing at a higher resolution than before and there's less///almost no notable FPS drops.

I'll report back another time when I have played more and tested more.

This is on the macOS beta client.
Slimig wrote:
mac improvements LOL

So, you said that Mac OS got performance improvenets, nice! Now we need to wait for normal client to get some tweaks, at least for me!
Annnnnd when will this be out for cosnole?
Patch is great! Whatever you did, the game runs much more smoothly for me now.
This is my first post as I have been playing this wonderful game only for a month (back to PC playing after years).

The game worked very fine for me since this evening. During the last days there were more and more short moments of lagging as I progressed through the chapters, but it has worked.
When I played it again this evening it was a complete desaster. In "the tower" (social hub of act 7) it started to freeze for round about one minute. The game didn't react to any controls anymore. When it came back to life all the (cached/saved) controls that I fired up during the time when it was frozen were spooled down within two seconds. The character was running like crazy from A to B to C, menus opened up and so on and so on. It also happened in any of the Ritual events that I started.

All in all it's not playable anymore! It must somehow be related to the latest patch or any special events that affect the infrastructure of the game this evening.

I absolutely enjoy this game and it's complex nature but I fear I have to stop playing till it has been fixed....
Exact same problem as above. I had ZERO problems until this last patch. Now the game is unplayable. The lag spikes occur every few seconds. Any advice from anyone out there?
Patch was about to kick me off at 8pm est. I signed off and waited til 915 then tried to get back on. I keep getting authentication failed when I hit start. I was on the title screen when I backed out and quick resume put me there again when I restarted at 915, but I did receive an error saying the patch needs to be applied and to restart - I did so. That’s when the issues occurred.

Device: Xbox series x
Exact error: failed to get authentication token

Edit: never mind. I didn’t do my due diligence and I thought a restart of the game (several times) was enough. After a hard reboot of the console it prompted me for the update it apparently didn’t actually install. I’ll leave this mistake of a post here for those with the same issue.
Last edited by HullDuck on Mar 10, 2021, 11:17:58 PM
Game is just getting worse and worse in terms of optimatization. This league I could'nt do 100% deli maps next league I will be probably unable to do even simulacrums and another one I will be stuck at T10 yellow maps cause game will be literally unplayable at the endgame.

Report Forum Post

Report Account:

Report Type

Additional Info