"Terror Tearing at the Seams" doesn't count Breach Bosses

The Challenge "Terror Tearing at the Seams" doesnt seem to count my Breach Boss Kills. I was running a Breach-Strategy at the Dunes-Map the whole day. I juiced the map with the Mod from the Map-Device and gilded breach scarab and all of the Atlas Skill Notables. In total i killed around 30-40 Breach Bosses today, but still got the same 21/50 completion on the quest. All my Breach Bosses were doubled through the "Tortoured Dreams" Atlas Node, maybe the interaction with this is buggy.
I tried the "recheck_achievements" command, didn't work.

Last bumped on Jan 31, 2023, 1:29:14 PM
This thread has been automatically archived. Replies are disabled.
Can confirm it is not working for me either. I am NOT running any breach nodes at all so it cannot be just that interaction being buggy. Just using scarabs. I killed 3 bosses today but none counted.
This is also the case for me, I killed over a few today and I'm still stuck at 28.
I have the same problem. Though killing breach bosses in Niko memory seem to count for some reason.
experiencing the same problem with breach bosses. not every breach boss counts for me.
still bugged ! was wasting my scarabs and device... fix it ggg!
I can confirm, I'm experiencing the same. I've been running breach juiced maps all day and killing loads of these buggers, but my number is stuck at 34/50 and not moving. Tried "/recheck_achievements" to no avail.
Confirming Bug on my end aswell.
Also experiencing the same bug. Any word?
Thank you for the reports, I have passed this onto the team

Report Forum Post

Report Account:

Report Type

Additional Info