PS4 Standard Atlas Zana not in map

Just finished Tier 1: Sulphur Vents Map, Zana is supposed to be there but did not appear. I ran the empty map several times thinking maybe I had missed something, but to no avail. Is this a glitch, or do they now only have a chance to appear?? Thanks :)
Last bumped on Jun 14, 2019, 3:09:04 PM
Hey there,

Are you referring to when you finish the quest 'Brave New Worlds'? Once you have defeated the map boss, you should be able to teleport back to the lab and talk to Zana for the quest to be completed.
I'll try it again, thank you for the quick reply!

Ok, no, so I do not have a new mission (I never fully completed the Atlas the first go). I did the Einhar map, he was there, I've tried to do the Zana map twice and she is not there, she does not appear. My "old" missions are still "The memory eater, collect the Shapers memory fragments (6/15)" and "Complete any Elder-influenced tier 12 map".

Edit 2: Jun did not appear in the respective map either.

Last edited by DragonSin1313 on Jun 12, 2019, 1:21:39 AM
Bump, I'm getting lost in the repetitive crash posts. Amalgamate your posts guys.

Report Forum Post

Report Account:

Report Type

Additional Info