No results showing up

Not sure if this is a bug or got something to do with my browser or computer or something, but no matter what items I look for or what filters I apply, I never get any results whatsoever. When I click on search, it says "searching" for about 10 seconds, but then goes back to the way it was before with neither items showing up, nor it saying that are none online.
It's pretty weird o_o

Edit: Now it works... no idea what the issue was.
I make dumb builds, therefore I am.
Last edited by FCK42 on Apr 11, 2018 6:07:57 PM
Last bumped on Apr 11, 2018 8:06:18 PM
You mean http://pathofexile.com/trade?
Yeah it's horrendous last 2 days.
Same issue for me :/
FeelsBadMan
Having the same issue. Started last night and hasn't gotten any better yet today.
Hi there,

Can I ask what language you're accessing the trade website with?

Cheers.
✮ Web Developer #2 ✮
🤔🤔
I'm using the english version. Haven't tried the german one yet, as I'm far more familiar with the english names at this point.
I make dumb builds, therefore I am.

Report Forum Post

Report Account:

Report Type

Additional Info