2.5.2d Redeploy

We have redeployed 2.5.2d, with fixes for its initial problems. This was deployed without a restart. Closing and reopening your client will update to this patch.

Last edited by Qarl on Feb 7, 2017, 11:08:45 PM
Last bumped on Feb 14, 2017, 7:40:24 PM
Way to go ! Continue supporting this great game. Thank you GGG.
Thanks for the redeploy!

Everything's smooth here w/ DX9Ex.
I don't check my posts. Once I post 'em, they're staying as-is. Best way to contact me is through the PM system.

Posted before this "2.5.2d redeployment announcement": https://www.pathofexile.com/forum/view-thread/1831010
Last edited by SoulProcurer on Feb 7, 2017, 11:47:49 PM

Thanks for the redeploy!

Everything's smooth here w/ DX9Ex.

I was running a map and during a Vagan mission I froze and crashed. (Around 8:10pm, Qarl posted at 8:08pm)
Right afterwards, I tried to restart PoE and had to wait due to a patch (this redeployment) and once I loaded the game up (Running DX9Ex) I had to wait at least 20 seconds between the area/map changes. The moment I "loaded" back into my Strand map, my screen completely froze and I waited 2 minutes before I locked my screen and alt-tabbed back into PoE, where I was told I was disconnected (obviously).

Now I switched to DX11 Beta and while I don't have the waiting time inbetween area changes, my movement feels much slower (graphics could be argued to look better but I can live with lower graphics as long as I can enjoy the game. I can't really enjoy if I die due to my screen lagging).

I don't know if anyone knows a fix for this or if I'm just now screwed and hoping that once I log back in 2-3 hours, the issue is relatively better.

I hope the majority of players in Wraeclast is having a more favorable outcome with this redeployment!
No more glyphing, great work
these ninja restart less updates really do not work. I was having a weird lag spike so logged off and tried the non steam client. I did not realize it had updated, then in the non steam client I noticed extream network lag, checked steam only to see its redownloading the whole game! A little heads up on these things could go a long way.
I opened the client only to find it saying that my content.gppk file was corrupted. Downloading it again right now. Maybe it's related ? I know it happens to people sometimes but for me it was a first.
I can no longer Alt + Tab out of the game.
"Alas, the one-man crusade of Torr Olgosso comes to an end. May his fervor for vengeance at being imprisoned inside of small boxes be remembered for all of time."
- Xedralya
When i attempt to load POE through steam it asks to download a 12GB patch that it didnt ask for yesterday.


Report Forum Post

Report Account:

Report Type

Additional Info