Game keeps loading as background process

this issue started since the blight league update. the game was running perfectly fine before that.

now when I try to start the game nothing happens. checking the task-manager shows it's running as a background process.

I tried running it as admin.
I tried the repair function.
I checked the PackCheck.exe.
I cleared the documents folder of poe.

I uninstalled the standalone client once, issue persists after reinstalling.
I killed the standalone once again, cleared everything poe related off of my pc, even checked the windows registry, reinstalled the standalone - issues persists.
I uninstalled it once again, installed it via steam. The first time I tried launching it, it didn't open at all. Task-manager didn't show it anywhere. Second time, and all the times after that, it once again runs as background process.

I searched the forums, I searched google, I've got no idea what on earth might be causing this. I haven't installed any new programs or softwares since I've last played, I haven't done any windwos updates. I'm not getting any error codes / messages either.

I'll highly appreciate any ideas that could possibly fix this so I can play again. And I really don't want to wipe my whole pc..

Last bumped on Sep 30, 2023, 6:59:05 PM
This issue has been plaguing a lot of people (me included) and the Devs keep ignoring the issue to the point where players are leaving the game. This is the most common issue alot of people are having and you are not the only one, It's sad that the devs and tech support aren't making a post or replying to posts like this. Once again you are not the only one so it's not your fault It's GGG not willing to listen to there players when players for years have been complaining about this.
Last edited by Oldwargoat39 on Sep 10, 2023, 12:01:34 PM
Same here

Report Forum Post

Report Account:

Report Type

Additional Info