2.5.1b Patch Notes (Restartless Deploy)

Patch 2.5.1b
  • The "Cannot Die" mod can no longer occur on Breach Commanders.
  • Corrected the Blade Vortex descriptions to line up with the change introduced in 2.5.1 where stacks add spell damage.
  • Fixed some issues with item price displays in premium tabs.
  • Fixed a client crash that could occur when adding a card to the divination card stash tab.


This has been deployed as a restartless patch. It won't require a realm shutdown, but the next time you restart your client it will update to it.

Last bumped on Dec 29, 2016 11:34:16 AM
Unfortunately now my client says I need to get the new patch, even though it's already installed... is this the DX11 bug again?
Looking for a mature guild to play with?
http://www.guildmedieval.com
Courtesy, Integrity, Fair Play.

I understand this is a role playing game, but I don't think the best role to play should be shopkeeper. - AlteraxPoe
patched....now i get "there has been a patch that you need to update to. please restart path of exile"


restart just gives the same error and patch already installed
same for me so far
Same issue as other guy, Just tried opening PoE on both normal and x64 clients and am getting an error upon trying to log in "There has been a patch that you need to update to. Please restart Path of Exile." However at the bottom right the client clearly says "release tags/2.5.1b"
Updated to 2.5.1b release tag (in client) and getting the same error: "Login Error. There has been a patch that you need to update to. Please restart Path of Exile."
Yup same here, and has nothing to do with DirectX 11 :p

Hope it's fixed soon !
Last edited by Afgnard on Dec 22, 2016 6:31:45 PM
same. i'm 32 and called my mom for help but she didn't know what poe was :/
^^ What they said.
same bug here

Report Forum Post

Report Account:

Report Type

Additional Info