[Official] WINE info thread

"
Ionlyplaynude wrote:
is this ge-3.6 better than https://aur.archlinux.org/packages/wine-staging-pba-git/ or is it the same?

Also how do I get working minimap?


They're pretty much the same when it comes to just PoE.
same name in-game
Just tested Wine ge-3.6 + DXVK on Lutris and ingame DX11, the FPS are a little bit worse than the DX9Ex version BUT all my crashes are gone. With DX9Ex about every twenty minutes I had an instance crash because it cant load textures (for example Error: -2147024882) but the change fixed it completely. If you get the same crashes definitely give it a try.
I'm playing on Linux Mint 18.2 and the game with PlayOnLinux with a 64-bit wine 3.8 virtual drive. The game runs well, although with some nasty lags at times. But more worryingly, a couple of times the game has crashed with a whole heap of error messages about Art/2D/....item

Have anybody come across this and is there an easy way to fix it? Both times it has happened it was while in the "home" area (Deadeye's Light? something like that).

I have a Nvida 770 GTX card and am using the 384.130 driver if that helps.


(Since I see it mentioned above, the minimap works for me)
Last edited by Pangaearocks on May 31, 2018, 8:19:07 AM
I don't know what they did with this expansion but the light is all screwed up - can't see anything in darker areas (caves, dungeons) so playing is pretty much impossible. Sigh... Everything was fine yesterday. Hope someone finds a solution!
"
You need that patch over here:

https://github.com/GloriousEggroll/ge-wine

IMHO, the easiest way to get that is via lutris, and install the ge-3.6 version of wine.


Thanks for the heads-up!
GloriousEggroll maintains an install script for Path of Exile on Lutris, but I don't know why he puts other versions of WINE, since Lutris itself recognizes one of his releases as a valid WINE version.

And now, since Lutris has a DXVK button, life's way better to get DirectX11+Vulkan working
"
I don't know what they did with this expansion but the light is all screwed up - can't see anything in darker areas (caves, dungeons) so playing is pretty much impossible. Sigh... Everything was fine yesterday. Hope someone finds a solution!


Same here, I'm on 3.6 staging, no problems yesterday. I patched, no more light radius. Any ideas?

ETA: If I have shadows on, I get a light radius. If I have shadows off, no light radius.
Last edited by garpu on Jun 2, 2018, 12:48:00 AM
"
garpu wrote:
"
I don't know what they did with this expansion but the light is all screwed up - can't see anything in darker areas (caves, dungeons) so playing is pretty much impossible. Sigh... Everything was fine yesterday. Hope someone finds a solution!


Same here, I'm on 3.6 staging, no problems yesterday. I patched, no more light radius. Any ideas?

ETA: If I have shadows on, I get a light radius. If I have shadows off, no light radius.


Yeah, i tried shadows - didn't help... What DX version do you use? Mine is 9ex.
"
Yeah, i tried shadows - didn't help... What DX version do you use? Mine is 9ex.


9ex. Antialiasing off, vsync on, shadows low, water low, textures medium, 2x anisotropic filtering, no post processing, no screen shake, engine multithreadding disabled.

My card's Nvidia 1050ti with proprietary drivers.
"
garpu wrote:
"
Yeah, i tried shadows - didn't help... What DX version do you use? Mine is 9ex.


9ex. Antialiasing off, vsync on, shadows low, water low, textures medium, 2x anisotropic filtering, no post processing, no screen shake, engine multithreadding disabled.

My card's Nvidia 1050ti with proprietary drivers.


I did a lot of testing over here. DirectX 9, 9ex and 11. For DirectX9 and 9Ex, I'm able to use staging 3.6 through 3.9. My reference staging 3.6 is the ge version. 3.9 is the standard staging.

Everything is setup through Lutris for practicality

My startup arguments are "-gc 2 --nologo -softwareaudio"

- DirectX 9 and 9Ex work perfectly and smoothly, but I have no shadows in dark areas, tested in The Sewers.

- DirectX11 works by combining ge-3.6 with DXVK (toggleable by Lutris). The game shows shadows and seems to work the same as 9 and 9Ex, but it stutters a lot more.

I've also noticed DirectX11 has Lighting and Shadows, whereas 9 and 9Ex only have shadows.

In all my attempts, DirectX9/9Ex did not produce shadows
- 32bit and 64bit client
- Shadows
- - Off, Low, High
- Antialiasing
- - Off, SMAA High
- Post Processing on/off
- VSync on/off
- Texture Quality
- - Medium, High
- Engine Multithreading
- - On just produces flicker
- - Off just doesn't flicker

Etc Specs:
- Linux Mint Cinnamon
- Lutris 0.4.18
- DXVK 0.52 (<- only works in DirectX11)
- Graphics Card/Driver - GeForce 740m/nvidia-390
If these are the shadows you mean, then I have them. I'm just playing with PlayOnLinux with wine 3.8, no fancy business. It has crashed a handful of times over the last week, though, with heaps upon heaps of error messages about 2D art, and fonts. Don't know if there is an easy way to solve that. Playing with Dx9Ex.


Spoiler

Report Forum Post

Report Account:

Report Type

Additional Info