Issues with Canada server

In last week, I had severals weird issues with the Canada (East) server. Those issues doesn't happen on any other servers I've tried (Washington, Texas, California to name a few).

1) Everytime, I try to login into this server, it tells me twice, "There's a new update available, please restart your Path of Exile client", but there is no update available. On the third try, it proceed properly.

2) When I login to the game from a "different" location, there's the usual message saying "Your account has been locked because you're connecting from an usual location. Please see your e-mails to unlock your account", which is fine, but on the Canada (East) server, again, it tells twice "There's a new update available, please restart your Path of Exile client", before it actually lock my account and ask for the unlock code from my emails.

3) Very often, I can see my Standard characters in the Ritual league only character list (the little dropdown league filter), but they're tagged has characters from the "<ERROR> League", instead of Standard and I can "migrate" them to the parent league, so Standard, which make no sense.

4) Along with the issue #3, I can also see, sometime characters from Void leagues... like The december 2020 events ones, which are supposed to have been deleted/removed. And, if i migrate a Void league character to Standard, I can acutally play it and start a game with it lol.

5) The login process to that server is, pretty often, VERY VERY slow. I can wait 30+ seconds before it actually respond with either a "Authentication failed", "Operation timeout" or it actually let me in. But, there are no latency or connection issues other the login and characters list issues.

6) I got kicked 3 times out of the game with the error message "This account is already connected elsewhere"... So I thought I got hacked, but after changing my password and doing some verifications, it happened a 4th time, again on Canada server, but not on any other one I've tried. It happened after I experience the issue #5 with "Operation timeout", so maybe, the server was so slow, that I was able to connect me to an instance, but after a while when it finally catched up, it tried to log me in, but I was already connected, so it kicked me out or something, I don't know.

I suppose these are server issues, because they don't affect my game pretty much, but that's a ton of weird stuff going on there.
Last bumped on Feb 28, 2021, 4:56:36 PM
Same thing happens to me, and whenever it says "There's a new update available" the next time I launch it, it'll make Steam verify the game files again.

Going back to character select will frequently time out or the game will just hang in a perpetual limbo, forcing me to close the game.

This stuff only happens with the Canada (East) server.
same here, and for me the game is literally unplayable around this time of night where i live. its so frustrating because i barely have time to play, and when i do, i spend a bunch of time restarting the game, changing servers or grinding lost xp from an instance crash. usually i just quit until i have time off
Its been the same for me also on almost all of those points.

Swapped to Texas realm for time being.
same, this is so annoying since washington causes tons of lag issues, love canada server except these new bugs ruin it

Report Forum Post

Report Account:

Report Type

Additional Info