Acquisition not Working

Not working for me either. I've tried restarting it several times but it hasn't helped. I've had this a few times in the past and it usually just fixes itself in a day or so. This time it has lasted more than usual though.
From League Starter to Shaper – Cheap, Tanky, Fast and Fun Physical ST – Very Detailed Guide

Gannicus, God of the Arena – Deathless Uber Elder for Everyone
same problem, need help :( or i die
I managed to run acquisition yesterday evening (after not being able to whole day), had it going and trading for couple hours with zero problems outside usual massages about old listings. Its dead again this morning. If it works again in the evening...
Same problem here, it stopped working since saturday night. I've been trying to reinstall it, without much sucess. Only got to login one time yesterday before the error came back.
Same here, it stopped working yesterday and I can't get it to work again. If they are forcing me to buy something to trade in their game I will quit. It's not a matter of money, it's a matter of principle, I mean it is 5$
still not working
If they did this on porpuse i will never spend another cent on this game and I will quit because im just so disgusted, unless they implement ingame auction house then i will come back, its just so hard to sell stuff without third party, just not worth the effort
It has stopped working again since yesterday

Report Forum Post

Report Account:

Report Type

Additional Info