Jewel Socket

I tried to apply a jewel to a jewel socket in my Passive Skill Tree, and after several attempts, with the jewel in my inventory, clicked on the socket with no jewel. The socket is "lit" as if filled - the jewel is still in my inventory. But there is no jewel or attributes associated with the empty, but de-activated socket.
Last bumped on Apr 15, 2019, 12:55:53 AM
Hi!

You need to allocate a skill point on a jewel socket in order to be able to use it. If you end up with a jewel in an unallocated socket, you will not gain its effect.

Hope this clarifies!
"
Kyle_GGG wrote:
Hi!

You need to allocate a skill point on a jewel socket in order to be able to use it. If you end up with a jewel in an unallocated socket, you will not gain its effect.

Hope this clarifies!


Ok - so now what? I have a "filled" but empty jewel socket!
"
Pictish wrote:
"
Kyle_GGG wrote:
Hi!

You need to allocate a skill point on a jewel socket in order to be able to use it. If you end up with a jewel in an unallocated socket, you will not gain its effect.

Hope this clarifies!


Ok - so now what? I have a "filled" but empty jewel socket!


Can you post a picture of what the socket looks like? It's possible you've now allocated a passive point for the jewel socket but haven't actually put the jewel in there. The socket lights up when you allocate it, similarly to any other passive.
I'm an idiot - didn't catch on that once activated I had to put the jewel in - thanks support person!

Report Forum Post

Report Account:

Report Type

Additional Info