Latency spikes in Incursions and then crash to login

So for about 3 weeks, I have had an issue that almost has gotten worse as I reached level 90 and thus more frequently complex enemies. Anytime there are a sudden spike in particle effects in game (common issues are the lightning pillars, the new fireballs with the incursion bosses, half the breach lords' attacks), my frame rate slows a tiny bit (I do have an older CPU so random spikes are the issue, the GPU is fine) but the real issue to me seems to be the latency to the server. I am normally running around high 30ms-low 40ms in the ping to your server in DC, but when there is this sudden spike either in an incursion or more rarely in a breach, it spikes to over 5000 instantly, hovers around 600 with a couple spikes back up to 3000-4000 ms. Then I am kicked to the login screen. Once in a while I will even find out my character died during this disconnection, although I think I tend to be saved due to being a summoner this league with my zombies saving my butt, I think the death count is over 10 times at least.

As you requested in the sticky note in the forum category, here is the link to my WinMTR data:
https://pastebin.com/FgaC4rZp
Seemed fairly good to me.
Last bumped on Jul 16, 2018 4:14:01 AM
log looks ok.

did you run it while having problems against the gameserver you were logged in?

to get a better indicator, if you get a laggy connection, grab the gamserver's ip address you're currently playing on from the game's logfile and run the mtr against that. ggg is highly interested in those logs.

--

if it's possible for you, try a different gameserver when you experience lag. your hideout will still reside on the old server but new instances will be created on the new one.

Yes it was to the only server I use, I live in the NE corner of the US, so Washington DC server is the only logical one to use, I could try somewhere else, but from what I have seen they are all having issues for some people, plus everywhere I would go would still have to have a jump or 2 on LEVEL 3 which is the worst and most unreliable high level in the world, but everything here routes through their NYC lines.

No I was not having issue when I ran it, I guess I could try to set up a likely to crash situation, like a high level incursion and run it while I try to force the game to crash, would that have good data?

Will update after I try a new server and a new log tonight.
So I have not tried another server yet, but I did get MTR to run before I went into and force a crash to log in with an incursion. Seems like the only difference is just before the DC server, might be worth trying a server more than double the distance.
https://pastebin.com/xivq57Um
"
cronus wrote:
log looks ok.

did you run it while having problems against the gameserver you were logged in?

to get a better indicator, if you get a laggy connection, grab the gamserver's ip address you're currently playing on from the game's logfile and run the mtr against that. ggg is highly interested in those logs.

--

if it's possible for you, try a different gameserver when you experience lag. your hideout will still reside on the old server but new instances will be created on the new one.



where do i obtain this log file?
i suspect it's one or more instance servers that the connectivity issues happen.

specific paths would help tremendously.
eg. e:\documents\mygames\pathofexile\???

Even if we found out which hop is having the issue, is there anything we players can do to avoid it?
It's really frustrating when ping/fps spikes from 16ms to 900ms then disconnect to login screen.
Highly infuriating when the instance is a valuable instance like Shaper/UberElder/UberAtziri or i83 temples.
I have an Alien pet.
Last edited by kelongngu on Jul 13, 2018 2:32:51 AM
"
Completed 22 Challengeskelongngu wrote:

where do i obtain this log file?
i suspect it's one or more instance servers that the connectivity issues happen.


i'm not on my pc atm, i think it's in the documents folder/mygames/pathofexile/logs/client.txt
or just search for client.txt

if you wanna test if the framerate is due to your computer or server related just switch from "lockstep mode" to "predictive mode" in the game's network settings.

in lockstep mode the client syncs the framerate to the rate the server responds, in predictive it doesn't wait for server packets to arrive.


if packets are delayed due to the server or some faulty router on your network path is not easy to find out as long as ggg doesn't implement some indicator in the client about the performance of your current server instance.

jonathan did mention in one interview that they thought about doing that so people don't blame the servers all the time. well, they didn't do it yet although it would fit percectly into the indicators you see when you press F1 ingame.
Last edited by cronus on Jul 13, 2018 12:18:46 PM
So I tried the other 2 servers in NA for a couple days each and no real change. The lag was slightly less noticeable when going from 80ms to 300 ms than when I was going from 30ms to 300 ms which makes sense to me, but they were still also getting the over 4 second ping and crash to login. Any advice or help is going to help me, it is rather frustrating to finally have a character that works well only to have the game not let me do the new content reliably.

Report Forum Post

Report Account:

Report Type

Additional Info