buying pack

hi , i tried buying pack for upgrading and the ''xsolla'' seem to bug i cant buy point from website to buy few stash in promotion :( i dont know if im alone in this case but its strange the bottun on the ''program'' work really bad
Last bumped on Jun 11, 2018 10:29:32 PM
Could you be more specific about what the problem is?

Have you tried using a different web browser?
the xsolia program for buying point per card on the website bugged as fuk , 3 days im trying to buy some point but the button on the application xsolia the hitbox are completly fuked up , so i want to know if im mthe only one the transaction never pass
look like if the program are surcharge by people, but it can be cool i buy my point before the end of stash promo ...
but the support dont look to care about $$$ , the support clearly suck in this game ...
Hey there!

I'm afraid you didn't provide us with your account details in your email to us, so we weren't able to fully look into this for you! As you have posted here though I was able to locate your email to us that way and check into this for you. :)

I've looked into this now and I have PM'd you with the details.
Contact us at support@grindinggear.com!

Report Forum Post

Report Account:

Report Type

Additional Info