Trying to get to Ruined Square - 20 crashes [Solved-ish]

I have to go from the town to Chamber of Innocence to Burning Courtyard(?) to Ruined Square. At some point along the way I have crashed 20 times trying to get there before just giving up. This is the same "known issue" that was in the known issues and this has not been fixed.

I was really hoping this last patch did the trick, but apparently not. *sigh*

[Solution]
Apparently switching to DirectX 9 after this last patch fixes my crashing issues (didn't before the patch). Running DirectX 9 is so bad and laggy, but still playable. I'm assuming the real issue was with my graphics card Nvidia GeForce 9600GT which is a good card but a bit old. I think it only supports features from DirectX 10 but not 11 (see debug info below).
Last edited by DeadMeatGamer on Aug 12, 2017 8:11:24 PM
Last bumped on Aug 12, 2017 8:03:35 PM
"
I have to go from the town to Chamber of Innocence to Burning Courtyard(?) to Ruined Square. At some point along the way I have crashed 20 times trying to get there before just giving up. This is the same "known issue" that was in the known issues and this has not been fixed.

I was really hoping this last patch did the trick, but apparently not. *sigh*


Hey,

We did patch in some things which we were hoping would fix this type of problem, and in some cases it did, but not all.

Can you please PM me your dxdiag and production_config.ini files so I can take a closer look.
Also, are you using any extra launch parameters at all?
✮ Please contact support@grindinggear.com if you need any help!
I wanted to rage quit not too long ago, haven't had a zone load related crash since switching to 64bit client.
"
Henry_GGG wrote:
"
I have to go from the town to Chamber of Innocence to Burning Courtyard(?) to Ruined Square. At some point along the way I have crashed 20 times trying to get there before just giving up. This is the same "known issue" that was in the known issues and this has not been fixed.

I was really hoping this last patch did the trick, but apparently not. *sigh*


Hey,

We did patch in some things which we were hoping would fix this type of problem, and in some cases it did, but not all.

Can you please PM me your dxdiag and production_config.ini files so I can take a closer look.
Also, are you using any extra launch parameters at all?


I sent off the info requested. No, I'm not using any launch parameters. Just in case it was a config issue, I saved the current production_config.ini to .bak and went with default settings. Other than needing to take off dynamic resolution because it was blurry I ran it as is and I still got crashes. Before I was reliably able to go through the labyrinth but now I get crashing there too which means I can never complete.

I global chat if they are having crash issues and I did get 1 reply to say it was constant for them as well.
I've been trying various things to debug with no success until I came across this:

"
2017/08/12 13:53:12 1715406 8d [INFO Client 7204] Enumerated adapter: NVIDIA GeForce 9600 GT
2017/08/12 13:53:12 1715437 254 [INFO Client 7204] Enumerated device for adapter: NVIDIA GeForce 9600 GT. Selected feature level: 40960. Max feature level: 40960
2017/08/12 13:53:12 1715437 145 [INFO Client 7204] Enumerated output for adapter NVIDIA GeForce 9600 GT of \\.\DISPLAY1
2017/08/12 13:53:12 1715437 8d [INFO Client 7204] Enumerated adapter: Microsoft Basic Render Driver
2017/08/12 13:53:12 1715437 254 [INFO Client 7204] Enumerated device for adapter: Microsoft Basic Render Driver. Selected feature level: 45312. Max feature level: 45312
2017/08/12 13:53:12 1715453 360 [DEBUG Client 7204] CreateSwapChain: SetFullScreenState 0
2017/08/12 13:53:12 1715453 3bf [INFO Client 7204] [DirectX] Runtime version = 11.1
2017/08/12 13:53:12 1715453 3c0 [INFO Client 7204] [DirectX] Feature Level = 10.0
2017/08/12 13:53:12 1715453 3c1 [INFO Client 7204] [DirectX] Driver Command Lists = YES
2017/08/12 13:53:12 1715453 3c2 [INFO Client 7204] [DirectX] Driver Concurrent Creates = YES
2017/08/12 13:53:12 1715453 3c3 [INFO Client 7204] [DirectX] Driver Constant Buffer Offsetting = YES


If the feature level is 10.0 then I thought maybe me having DX11 in the settings is too high, so I switched to DX9. Now when I went to the torched courts which reliably always crashed now let me in. I even made it to the Ruined Square. I know prepatch switching to DX9 made no difference, but apparently it does now. I'll let you know if I get an outofmemory error following this post.

This is still a bug IMO, but at least I can play the game now... so far.
So, switching to DX9 has apparently fixed the issue, but it's so laggy. Much smoother gameplay with DX11.

Report Forum Post

Report Account:

Report Type

Additional Info