Poor latency issue (SG server)

Been experiencing unusually high latency for SG server for the past 2 weeks, be it normal or beta play through.

WINMTR as below:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| No response from host - 100 | 462 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 462 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 462 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 461 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 461 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 461 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 461 | 0 | 0 | 0 | 0 | 0 |
| 5b.cb.0cd8.ip4.static.sl-reverse.com - 0 | 461 | 461 | 229 | 230 | 239 | 232 |
|________________________________________________|______|______|______|______|______|______|
WinMTR - 0.8. Copyleft @2000-2002 Vasile Laurentiu Stanimir ( stanimir@cr.nivis.com )
"Abandon all hope, ye who enter here." ಠ_ಠ
Last bumped on Jul 12, 2017 6:42:50 AM
Hey there, Could you please send us an email to techsupport@grindinggear.com? We may be able to assist you with this.

Please ensure that any WinMTR report generated is using the latest version. This is currently 0.92 and you can find this here: https://sourceforge.net/projects/winmtr/files/Latest/

Report Forum Post

Report Account:

Report Type

Additional Info