Stuck at loading instances

"
Yep, despite the servers coming back up, having 30-40 minutes of the race time taken away without a word from GGG is disappointing. What a waste, looked forward to this race and server drops


Yep. I've lost all hope for 3.0, they're just getting too ambitious for their QA team. Without a better QA team, even AFTER a month of beta, I expect 3.0's release to be far more crash-prone than past expansions. Sometimes I wonder what the QA team is doing with their time... I've seen a lot of games with similar complexity manage to ship similar content with far fewer standing bugs, and if even merely one significant feature like the MTX refactor can go this far wrong, well...

"
Hi GGG,

Why you didn't schedule this update?

I've spent a lot chisels, vaal orbs and chaos orbs for few maps and every disconnect loose my opened portals...


That's why I shun map and lab content and play content that results in less loss on server/connection issues instead. Trust me, it's far less frustrating. It would have been even less so if they'd just bring over Leaguestones so we can actually get league content in non-maps instead of having to play through most of the campaign just to get old league access and then accept the loss of what can easily be a fairly expensive map instead of a fairly inexpensive leaguestone if the server drops while running it. Leaguestones are so much better a system than PoE-style maps. Torchlight 2 maps are also far superior - and Torchlight 2 doesn't even suffer from the drop issue anywhere near as much.
People who don't like the Labyrinth are not a minority: Be heard - say you don't like it in your signature. Don't leave complaining about lab to others - GGG needs to see how many people dislike it. Ascendancy must be gated on true ARPG content, not a poorly-crafted internet Legend of Zelda wannabe.
edit: wrong thread, sry guise
Last edited by HairyNugget on Jun 9, 2017 10:13:03 PM
Just adding to this -- also can't load like, every other instance. This means I can't do lab, can't ascend, can't really do temples either. Only started recently. Please resolve this - it seems to be an ISP issue with Spectrum in California
Me too. It seems to help to change servers. Went from CA to Texas now DC. Each change works for a while then stuck at loading instance.
Please don't bump old threads (although impressively this was bumped a year and a day later).
Has Any Exile Really Been Far Even as Decided to Use Even Go Want to do Look More Like?

Report Forum Post

Report Account:

Report Type

Additional Info