PROCUREMENT : The Ultimate Path Of Exile Companion Tool [Latest Version: 1.9.2] NEW!!

Is there any way to use the search function with the inventories of all your characters? At the moment I can only search my stash.
is this safe
"
Completed 1 ChallengeBrisk wrote:
is this safe


idk
WHat is the Key for (AllGems)

i dont wanna make 5 tabs... i will all Gems in one Tab but what is the key?
Is there a way to prevent an item from showing up under more then one category?

Lets say In My Stash Tab # 2 I have a 5 Link Rare Chestpiece with 17% Increase Item Rarity.

My first category shows all my items in Stash Tab 2 with a buyout of 7 Chaos. So this Chestpiece shows in here for 7 Chaos.

But then I have a category for 5 Links with a buyout of 5 chaos. The chestpiece shows up again and has a buyout of 5 chaos.

Then I have a category for Items that Increase Rarity / Quantity with a buyout of 8 Chaos. The Chestpiece shows up again with a buyout of 8 chaos.

Then once again, under my Armor > Chestpiece category, It shows up again for 4 Chaos.

Can you guys at procurement make a fix that prevents Items from being entered in more then 1 Category. I don't know the best way to do this, but the first thing that comes to mind is:

EITHER:
A) The first category it shows up in is the buyout that shows up on poe.xyz
OR
B) The last category is the buyout that shows on poe.xyz.

Have you guys been aware of this? And if so have you been looking into possible solutions?
Standard League
Lokailith - Level 100 Max Block Static Strike Marauder
Ranked #87 In World
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Streaming @ twitch.tv/levy42088
The program is not generating my gem tabs properly. I have for example 143 gems in one tab, but it only places 73 into the code for the forum.

Anyone know why it does this? The tabs have general buyouts, but the gems do not.
The gems not displaying is because by default the Procurement template does not include ALL gem categories, you have to decide how you want them displayed (check the wiki). I'll be updating default template in the next release however, because this issue keeps popping up.

Speaking of next release...

qL5KbhJ
Procurement  : The Ultimate Exile's Companion!
Forum Thread : http://bit.ly/1hhSmro
Google Code : http://bit.ly/1lD34f4
Wiki : http://bit.ly/1iHZoLA
FAQ : http://bit.ly/1ik51gp
Why does it try to change HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Tcpip\Parameters ?
PS. yeah, I'm a bit paranoid :)
PPS. It doesn't actually change anything in there as far as i can see... but why does it try?
"
silumit wrote:
Why does it try to change HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Tcpip\Parameters ?
PS. yeah, I'm a bit paranoid :)
PPS. It doesn't actually change anything in there as far as i can see... but why does it try?


Edit: Ok, I went and double checked and Procurement does access that key when you login, but that is .NET accessing that key to be read. Any windows application that does multiple network calls will access that part of the registry.

You'll notice for example that Procurement also reads

HKLM\SOFTWARE\Wow6432Node\Microsoft\Cryptography\Defaults\Provider\Microsoft Enhanced RSA and AES Cryptographic Provider

When it encrypts the password, this is all done by .NET.
Procurement  : The Ultimate Exile's Companion!
Forum Thread : http://bit.ly/1hhSmro
Google Code : http://bit.ly/1lD34f4
Wiki : http://bit.ly/1iHZoLA
FAQ : http://bit.ly/1ik51gp
Last edited by Stickymaddness on May 11, 2014 3:02 PM
"
"
silumit wrote:
Why does it try to change HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Tcpip\Parameters ?
PS. yeah, I'm a bit paranoid :)
PPS. It doesn't actually change anything in there as far as i can see... but why does it try?


Where did you download Procurement from? There is nothing in the code that touches the registry!
Ehm, from github - the link in OP, then https://github.com/Stickymaddness/Procurement/releases/download/1.3.1/Procurement.1.3.1.zip

If I forbid registry change, then
"

Procurement 1.3.1 Initialized.
                                                           
Authenticating <my_email_was_here>                                                  

[Error] Can not resolve remote name: 'www.pathofexile.com'

If I allow, then it works. There are no visible changes to that part of registry anyway...
NB. it works, but log looks strange, something like this
"
Loading Image For Orb of Alchemy              
Loading Image For Orb of Alchemy              
Loading Image For Orb of Alchemy              [ok]
each line shows 3 times but there's only one [ok] thing
upd. It crashed xD. Started again, this time in Comodo sandbox. Well, at least log looks norm now, will see how it goes this time...
Last edited by silumit on May 11, 2014 3:09 PM

Report Forum Post

Report Account:

Report Type

Additional Info