Unable to connect to patching server.

So haven't played PoE in a couple of months, come back and obviously find a big update. I go afk and eat while it's updating, no problems so far. Come back and it's almost done. The next time I check on it it has an error message saying 'unable to connect to patching server'. I thought this was strange because I have just updated a couple on minutes ago, if that. So I looked here on the forums to see if anyone else had the same trouble. Found an old thread that mentioned allowing it through windows firewall. Added PoE to firewall allowed programs and still no luck.

TL;DR - Updated client, afterwards error message: 'Unable to connect to patching server' appears.

If anyone has got any idea on how to fix this please tell me.
Thanks :)

EDIT: Also tried running as admin, didn't work either.

EDIT #2: PoE seems to open instantaneously and show this error message, which is strange as my laptop doesn't open any programs that fast. Seems more like it is already running, but I checked on my toolbar, and on the programs and processes tabs on task manager and it isn't on any of them, unless it's on processes under a different name.
Last edited by JacobKant on November 11, 2012 6:21 PM
The process will just be called Client.exe, but it shouldn't be running prior to you starting it. The patcher does just tend to start pretty fast as it's fairly light weight.

I would suggest you try disabling any firewalls/antivirus or other security programs you might be running and see if that fixes the problem - if it does you can re-enable them and try to figure out which one is blocking the patcher.
Thank you for responding so quickly :)I disabled windows firewall and my antivirus, but still it didn't work. I don't think it would be that anyway as I had connected and updated my client just before this started to happen, but now it comes up with the 'unable to connect to patching server' before I get the update log screen. Seems more like something in the software, maybe something from the update that stopped it working?
As far as I'm aware there shouldn't be any way for a patch to cause this directly. You could try download a new copy of the installer and reinstall the game (back up your Content.ggpk file first in the games install dir, so you don't have to re-patch everything).

You could also try using an alternate patching port, in case something upstream of your computer has blocked the port somehow. To try this, create a shortcut to the Client.exe file (or use the default shortcut on your desktop), right click the shortcut and go "Properties", then go to the "Shortcut" tab, and append " --patching-server pathofexile.com:3724" to the end of the "Target" box. So assuming a default install dir the "Target" box will look like:

"C:\Program Files\Grinding Gear Games\Path of Exile\Client.exe" --patching-server pathofexile.com:3724

(or possibly with "Program Files (x86)" if you have 64 bit OS). Then run the shortcut normally.
Ok it seems I have lots of problems with my laptop (windows update and security centre not turning on, not being able to connect to servers on other games too), which I think have been caused by malware I had recently. Going to have to reinstall windows, and I'm guessing whatever has caused those things to stop working also stopped PoE from working :( Thanks anyway Thomas :)
Hi,

I apologize for my english if it's bad at some point of this message.

I may be doing some digging by answering this thread, but after I had some problems with this error on the mac port, I just wanted to write this, maybe it will help someone.

You have to do the same thing, but for that, first open the app with a right click (open content, I run on a french version since I am, but i guess there's something similar. Anyway, it's the second option from the top, on the right click menu.
Then you launch Wineskin, you go to Advanced options, and in the field "Custom commands", you copy here/paste there the same string :

"
--patching-server pathofexile.com:3724


BUT !
One thing you must not forget, is to put a space right before the "--". It can seems obvious, but it pinned me down for a while.

Well....that's all I wanted to add to this thread.

Thank you for reading, and sorry again for the post's syntax if it's not exact.

Report Forum Post

Report Account:

Report Type

Additional Info