Constant disconnects when loading zones

This isn't just me? I've always had these type of disconnects, but I could circumvent it by using different towns as my load-in area and just staying in my hideout. Now, with the Azerite mine I need to load to, it's become exceptionally frustrating.

I need to load it twice. So I load it once, wait till I disconnect - which takes forever - and then load again. The same happens with towns, which means that it often takes at least 10min of loading and disconnecting before I can get into the mine.

Oh, after this I have to stomach the 3 FPS I'm getting when fighting near the glowing live Azerite veins. I realize that my PC is a bit older, but it runs more graphical intense games a lot smoother. It's absurd how I can have smooth gameplay in on environment and absolutely tank my DPS in the next.

I'm afraid I'll have to skip this league at the very least and wait till GGG gets the performane of their game more ironed out or until I get a hefty PC upgrade, which won't be soon.
Last edited by Ivonbeton on Sep 5, 2018, 5:19:44 PM
I'm gonna have to go ahead and add my voice to this outcry -- I've been playing since closed beta, and I have never had a complaint about lag or anything of the sort in the game.

PoE has always run like butter for me, nice and smooth.

Delve releases and it's like someone switched my butter with chunky peanutbutter and bubblegum.

What in the actual hell? I can't even get into a town because of disconnects and authentication errors. And god help me if I do, because i better play for 12 hours straight, since the connection gods won't smile upon me again for another 24 hours.

GGG Please find the source of this issue, as I'm loving the Delve league, but it's getting to be intolerable.
It is the nature of man to create monsters,
It is the nature of monsters to destroy their creators.
Same thing here. I understand I have not the fastest HDD and only 4GB of RAM, but come one... game worked almost flawless during Harbinger. There were some unexpected disconnections during Bestiary or Incrusion, but it was like one in hour, and that I could stand without problem. Now it is literally impossible to play. I tried every launch command possible (noasync/waitforpreload etc.) and tried to play in all different settings... nothing worked. Getting load into town is like 2-4 tries, today it was literally impossible to load mines (it took me 6 times, then I gave up after doing one delve - game disconnected when I tried to do next not-connected to previous route).

Don't tell me "upgrade PC" because game runs 40-70 FPS on DX11 with almost everything set to highest. Also I am able to play much more demanding games.

I just have to quit, it is like 20 minutes of going back to menu and load again to play for 15 minutes. I am ok with long loading times if the game will not crash. I can wait those 2 minutes to play, but not to go back to menu. Game is unplayable at this state. And this is a shame, because I really, really wanted to purchase some tabs and microtransactions, but it is just pointless at this point.
Last edited by Ravebow on Sep 7, 2018, 1:14:16 PM
I'm gonna chime in too, the game is completely unplayable, I get disconnects every 10 seconds to 2 minutes max during peak hours. I tried playing today (Saturday) and it's impossible. Fun fact - when I'm playing early morning on the weekdays, the game runs flawless, without a single hiccup. So it's 100%, guaranteed problem on the GGG server side.

I posted on the forums, with my WinMTR results, which are flawless, up to a single hop, that's ae5.cbs01.eq01.ams02.networklayer.com where I have a constant packet loss, from 15-50%.

And I tried changing servers, contacting the support on forums, sending an e-mail to the technical support proved to me that GGG are incapable of solving the server problems. The support guy told me this:

"I am seeing a high latency spike on your second hop which continues further down the line:
| cable-178-148-232-1.dynamic.sbb.rs - 0 | 505 | 505 | 5 | 14 | 135 | 14 |, and I can see higher than optimal latency to your router."

So just for people to understand, first number is the % of packet loss, which is 0, 2nd and 3rd column are the sent and received packets, 4th, 5th and 6th columns are lowest, average and highest pings, and the 7th column is the last ping. So this man, who's supposed to be an technical support expert told me that my 14 average latency is "higher than normal". What else to expect?

It's a shame that a game this great is being held down by horrible management and servers, and until it gets fixed, I'm not spending a single dime on it.

Btw, I'm on EU.
Same for me, I manage to play the previous event but this become just unbearable. Login, loading for around 3 min and "unexpected disconnection", 2 tries more and finally the town and click any zone, ...loading... "unexpected disconnection", got to hideout, may get slow but I manage to move around there, go to another zone...well you know same stuff all over.

I am on Australia
Last edited by chucho2013 on Sep 9, 2018, 9:19:58 AM
I have the same issue and I do have a theory. If someone else has already mentioned this, I do apologize. I read a response on here that the problem went away or didn't occur when using a SSD drive. What it seems to me is that when you load the game itself, your computer starts to move over a ton of data from the hard drive to RAM. It will fill up your RAM at the rate your disk drive can handle. If you log in with a character, the game will start again to load data from HD to RAM. The server is probably waiting for your computer to make the transfer and if you take too long, you will get timed out by the server. I seem to see a decrease in disconnects when I wait for the game to load fully before logging in. Thankfully, the game doesn't clear your RAM from your initial load/disconnect; making the consecutive attempt more likely to be successful. Perhaps POE reduced the time-out period at some point in an effort to reduce overall load on the servers. I think the main solution for us though is to move to using SSDs. Otherwise, we will need to be patient with our slow HDDs.
Add my complaint in... It happens especially after 3.4 Delve patch. I will get kick out every time when trying to change map. Until these 2 days it has become so serious to the extend that I first log in, enter into hideout, got kick out, and then I will stuck at character selection screen and will never able to log in anymore due to "unexpected disconnected".

Edit: This game is officially dead!
Last edited by ChickyWaWa on Sep 16, 2018, 4:08:22 AM
I've tried every solution from ssd to reseting virtual memory to deleting cache folders, parameters, to 32 bit... if it's been suggested I've tried it.

The *only* thing that works for me, and it's a poor solution is using a VPN. I've yet to find one that gives me stable latency however. If anyone knows of one with servers in Texas or Washington, a heads up would be great.

So far I've tried PureVPN (garbage), VyperVPN (decent, but other issues), and NordVPN (VERY sporatic).

Anyways, give a free one a shot to see if it works for you.
I have a brand new machine. Less than 2 months old. When I first booted it up and loaded everything it was butter smooth. All lags erased, game ran perfectly. Then this Delve league starts.

Now I have all the problems I used to have plus new disconnections. Literally the game is NOT PLAYABLE.

I spend long times loading screens. I can't play longer than 15 minutes.

My biggest problem is now when the game freezes that's all she wrote. Nothing will work, especially not task master.

The only thing to do is reboot the entire machine. I am quitting this league and POE a while which really ticks me off. I was about to buy new tabs etc but it is pointless. Why should I spend money on a game I can't play!

This is what pisses me off the most! I really really really like POE. Go fig.
I TO CANNOT STAY LOGGED IN. FIX THIS SO I CAN. I HAVE SPOKEN

Report Forum Post

Report Account:

Report Type

Additional Info