Won't let me download

I just got invited to the beta and clicked the link to download the game, but it just sat there doing nothing.

It's also not letting me download by clicking the Download Now! button.

I saw a thread saying that you could download the game from Deposit Files..which I've tried, but gives me a web page error.

Is there some other way of downloading the game? Is there some kind of server maintenance going on, and that's the reason I cannot download?

*edit* rebooted PC and tried to download again and this time I got to 2.4 mb of 6.6 before it froze. Guess I'll keep trying.

*edit* okay I got it. Just kept pausing and playing until it finished. Hopefully it works!
Last edited by thelonelypig on November 22, 2011 7:32 AM
Cross fingers for you ;)
Joined: 28 septembre 2011 07:21
Get the Beta the 24 november 14:55
Thank to icassel for the Bkey
make sure your POE register account that have key has log in

if is still error ask other player to upload the installer for you its only 7mb size the patch is the big one

Report Forum Post

Report Account:

Report Type

Additional Info